1

I have installed WSL on windows 10. After that using VcXsrv, I can launch gedit editor from the installed WSL. Moreover, I have tried to install Arabic and Persian language using this link, and it was successful.

Anyhow, the question is how can I write in Persian in a launched gedit in WSL? I should have mentioned that changing the language of windows to Persian does not help me to write Persian on gedit anymore.

enter image description here

closed as off-topic by muru, Elder Geek, user364819, David Foerster, Eric Carvalho Feb 21 '18 at 16:09

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This is not about Ubuntu. Questions about other Linux distributions can be asked on Unix & Linux, those about Windows on Super User, those about Apple products on Ask Different and generic programming questions on Stack Overflow." – muru, Elder Geek, Community
If this question can be reworded to fit the rules in the help center, please edit the question.

  • Could you please edit your question to include the output of locale? Thanks. – David Foerster Feb 21 '18 at 11:08
  • To close voters: WSL is not generally off topic. While graphical applications in that environment are problematic, locale settings should work in a similar fashion than in any native Ubuntu installation. – David Foerster Feb 21 '18 at 11:10
  • To close voters: This is definitely an on-topic question about Ubuntu Bash on Windows aka WSL (Windows Subsystem for Linux) which has it's own tag here in Ask Ubuntu. – WinEunuuchs2Unix Feb 21 '18 at 11:25
0

From SuperUser:

The Windows Subsystem for Linux (WSL) installation should automatically set the Ubuntu locale to match the locale of your Windows install. You can change the Ubuntu locale manually using the shell.

sudo update-locale LANG=en_US.UTF8

Replace "en_US.UTF8" with your desired language. If you have any problems visit the link for extra steps.

  • Thanks. As I mentioned I want Persian language. Hence, I have tried LANG=fa.UTF8 but it does not work. Getting this error: *** update-locale: Error: invalid locale settings: LANG=fa.UTF8. – OmG Feb 21 '18 at 11:34
  • I've never changed the language myself. I suggest posting your error message in the comments of the SuperUser link above. – WinEunuuchs2Unix Feb 21 '18 at 11:37
  • I did this. It does not work. Again, the language in gedit is in English. – OmG Feb 21 '18 at 13:51

Not the answer you're looking for? Browse other questions tagged or ask your own question.