0

I just installed Ubuntu 16.04 a couple days ago.

I can't play facebook videos on firefox. When I click on the video the page just refreshes and nothing happens.

Ihave no extensions installed and I've already removed firefox and installed it again but the problem still persists. I also have a black screen on twitch, though the audio is fine. On the other hand, videos and twitch work on Chromium

What I've tried

  • Re-installed firefox
  • Re-installed adobe flash player (not sure if did it right)
  • Restarted my computer

closed as unclear what you're asking by David Foerster, Kevin Bowen, K7AAY, user535733, Eric Carvalho Jul 3 '18 at 11:50

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • Refer askubuntu.com/questions/16758/… to remove firefox and reinstall. – Sanjay Prajapat Feb 19 '18 at 14:45
  • I did what it said in that guide. but nothing changes, i still can't play Fb videos – zakaria hilali Feb 19 '18 at 15:52
  • did you install flash? – ravery Feb 19 '18 at 16:04
  • 2
    Could you please edit your question to include the output of the terminal commands lspci -nnk | awk -v n='[0403]' 'p&&/^\S/{p=0}!p&&index($0,n){p=1}p', aplay -l, pactl list short sinks, and pactl list sink-inputs | gawk -v name=firefox -v RS='\n\n' 'index($0, name)'? Please also make sure that the relevant audio channels in alsamixer (terminal) or gnome-alsamixer (GUI) have their volume turned up and aren’t muted. Thanks. – David Foerster Jul 2 '18 at 10:44
  • 2
    The output of dpkg-query -Wf '${Status;1} ${Package} ${Version}\n' 'gstreamer*-plugins-*' | awk '$1 != "u" && $2 !~ /-dbg$/ { printf("%s\t%s\n", $2, $3) }' might help too. – David Foerster Jul 2 '18 at 11:17
6

I've had this problem in the past with videos on all versions of Ubuntu & Firefox, YouTube seems to work fine but nothing else like nfl.com, facebook and news websites videos.

I’ve recently installed Ubuntu 18.04 and it seems to have cured this problem by going to the Ubuntu software icon, and going to the add-ons category, then select the codec tab and found 12 gstream selections with 6 already installed. I installed 2 of the first ones, and my problem was solved: I can now play any video from any website.

0

Install the GStreamer OpenCV plugins

sudo apt-get install libgstreamer1.0-0 gstreamer1.0-plugins-base gstreamer1.0-plugins-good gstreamer1.0-plugins-bad gstreamer1.0-plugins-ugly gstreamer1.0-libav gstreamer1.0-doc gstreamer1.0-tools

  • 1
    how should they do that? explaining why it would help would be nice too – Zanna Jul 1 '18 at 7:26

Not the answer you're looking for? Browse other questions tagged or ask your own question.