When I try to open a .psd file using gimp I get this error:

Opening '/media/anonoymous/Other's/Practise/bootstarp/design.psd' failed: Could not open '/media/anonoymous/Other's/Practise/bootstarp/design.psd' for reading: Permission denied

What should I do?

  • 3
    Please add the output of the command ls -l /media/anonoymous/Other\'s/Practise/bootstarp/design.psd to your question. Also, check if the path is valid, it contains multiple misspelled English words. – Melebius Feb 19 '18 at 11:19
  • Is the file on an NTFS (Windows) partition? Please also give the output of mount – Zanna Feb 19 '18 at 11:38
  • You should try to add this file as sudo, it looks like you have it mounted in a shared drive with windows... Usually this kind of mounting have all files with owner and group as root – Alvaro Niño Feb 19 '18 at 12:40
  • Possible duplicate of How to get permissions to execute programs from NTFS hard drive? – Elder Geek Mar 29 '18 at 17:16

I was able to correct this error by giving the gimp snap access to the removable-media plug by entering the following command:

snap connect gimp:removable-media :removable-media

Best of Luck

  • I needed sudo to run this command. – Maddenker May 11 '20 at 21:06

The Ubuntu Software program now has a way to set permissions on the page for the snap software with this issue. There is a 'Permissions' button under the name of the program.

The page for GIMP in the Ubuntu Software program, showing the Launch, Remove, and Permissions buttons

Click that, and then click the button next to where it says 'Read/write files on removable storage devices'

enter image description here

You will be prompted to enter your password. After that the problem is solved.

Ubuntu will regard internal drives other than the drive with the Ubuntu OS as removable storage devices too.

  • this should be accepted – php_nub_qq Mar 1 at 12:24
  • Thanks that worked like a charm and helped me out quite a bit! – Obnebion May 26 at 8:10

Gimp wouldn't open any files for me, even when I fixed the permissions. I deinstalled the snap version, and reinstalled with

sudo apt install gimp

and the problems went away.


I had an analogous problem but with .pat file. My problem was actually that the owner and the group of the file (check it by using the command ls -la) was set to root for some reason. I changed it with chwon myuser:mygroup myfile to the local user and the problem was solved.

Good luck.

Not the answer you're looking for? Browse other questions tagged or ask your own question.