41

When I try to open a .psd file using gimp I get this error:

Opening '/media/anonoymous/Other's/Practise/bootstarp/design.psd' failed: Could not open '/media/anonoymous/Other's/Practise/bootstarp/design.psd' for reading: Permission denied

What should I do?

4
  • 3
    Please add the output of the command ls -l /media/anonoymous/Other\'s/Practise/bootstarp/design.psd to your question. Also, check if the path is valid, it contains multiple misspelled English words.
    – Melebius
    Feb 19, 2018 at 11:19
  • Is the file on an NTFS (Windows) partition? Please also give the output of mount
    – Zanna
    Feb 19, 2018 at 11:38
  • You should try to add this file as sudo, it looks like you have it mounted in a shared drive with windows... Usually this kind of mounting have all files with owner and group as root Feb 19, 2018 at 12:40
  • Possible duplicate of How to get permissions to execute programs from NTFS hard drive?
    – Elder Geek
    Mar 29, 2018 at 17:16

4 Answers 4

60

I was able to correct this error by giving the gimp snap access to the removable-media plug by entering the following command:

snap connect gimp:removable-media :removable-media

Best of Luck

1
  • I needed sudo to run this command.
    – Maddenker
    May 11, 2020 at 21:06
50

The Ubuntu Software program now has a way to set permissions on the page for the snap software with this issue. There is a 'Permissions' button under the name of the program.

The page for GIMP in the Ubuntu Software program, showing the Launch, Remove, and Permissions buttons

Click that, and then click the button next to where it says 'Read/write files on removable storage devices'

enter image description here

You will be prompted to enter your password. After that the problem is solved.

Ubuntu will regard internal drives other than the drive with the Ubuntu OS as removable storage devices too.

4
  • 1
    this should be accepted
    – php_nub_qq
    Mar 1, 2021 at 12:24
  • Thanks that worked like a charm and helped me out quite a bit! May 26, 2021 at 8:10
  • This worked for me - permission to access removable drives was turned off May 14, 2023 at 1:31
  • Thank you! For the longest time I have been mystified about why my applications cannot see my network drive but I can see it just fine from the shell or file manager. GIMP gave me a clue with an error, but others just fail silently. The GIMP error led me here. Problem now solved. Jan 28 at 1:45
3

Gimp wouldn't open any files for me, even when I fixed the permissions. I deinstalled the snap version, and reinstalled with

sudo apt install gimp

and the problems went away.

1
  • This will only circuvent the problem. The problem ist the permissions of the snap package: when installing with apt you will have two separate gimp-installations. One as snap and one as deb. See @andrew s solution
    – jvoigt
    Jun 21, 2021 at 5:52
1

I had an analogous problem but with .pat file. My problem was actually that the owner and the group of the file (check it by using the command ls -la) was set to root for some reason. I changed it with chwon myuser:mygroup myfile to the local user and the problem was solved.

Good luck.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .