5

When using a program, for example Libre Writer, when I click on file, open, then in the Open menu box I have the opportunity to change the file type from "All files" to a specific file type, when I click on "All files" the selection list appears. The font color for the different file types is a dark grey on a black background making the list items illegible. As I move the cursor, the font color and background change to "normal" black on a white background but only for the item that the cursor is hovering over at that moment. This makes the rest of the list impossible to read and moving the cursor slowly down the list, pausing to read each item, is a very cumbersome way to get things done.

This doesn't just happen on Libre Writer but also Inkscape, Geeqie, and a variety of other programs and their sub menus. The only program I could find where this didn't happen was Firefox (58.02). Furthermore this happens on 3 different machines, each with a different processor, different graphics card and where the machine has multiple monitors, it happens on all monitors.

All machines are running 16.04, one with the latest updates, the others slightly behind on updates. Is this a bug or a "feature". Haha. What is going on? Is this fixable? How?

  • Go to your settings menu, select Appearance icon and then change the theme to say "Ambiance" and try that. – WinEunuuchs2Unix Feb 19 '18 at 15:47
  • Was set to Ambiance by default, so I switched it to Radiance and that works. Odd that the default setting has this defect. Any idea how to report this to the maintainers? – KalaDude Feb 19 '18 at 20:18
  • You can report it at Launchpad.net. I've never reported a bug myself but have read a dozen or so. After changing it to Radiance can you change it back to Ambiance and see if that one works ok now? – WinEunuuchs2Unix Feb 20 '18 at 23:33
  • Changing back to Ambiance did not resolve the issue. So I reported the bug. Bug reporting method is to press Alt F2, type in "ubuntu-bug". If it's for a specific program then type in "ubuntu-bug <program name>" then follow instructions. After a few steps, questions and data collection, it takes you to launchpad.net. This bug was assigned Bug #1750973 if you are interested in seeing how it is resolved. Thank-you for your kind assistance. Aloha! – KalaDude Feb 22 '18 at 7:20
  • Thanks for bug reporting methodology. I hope they provide a solution soon. – WinEunuuchs2Unix Feb 22 '18 at 11:17
2

Below appears to be a minimal change which fixes these pop-up menus.

  • As a backup, make a copy of file /usr/share/themes/Ambiance/gtk-2.0/gtkrc :

    cp /usr/share/themes/Ambiance/gtk-2.0/gtkrc ~/Documents/gtkrc
    
  • Using sudo, edit the file /usr/share/themes/Ambiance/gtk-2.0/gtkrc :

    sudo vi /usr/share/themes/Ambiance/gtk-2.0/gtkrc
    
  • Go to (around) line 346 (346G) which should read:

    style "menu" = "dark" {
    
  • Remove this: = "dark"

  • The line should now look like this:

    style "menu" {
    
  • Save your changes (ZZ)

  • Open the Systems Settings app

  • Go to the Appearance section

  • Change the theme from Ambiance to something else, and then back again to Ambiance (this will refresh your theme)

Tested under Ubuntu 16.04. The exact line to change may vary depending on what patch level you have. A safer way of finding the line to change is to search for style "menu" = "dark" in the file. In vi this would be: /style "menu" = "dark"


Before the change:

Inkscape menu


After the change:

Inkscape after change

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.