0

I built my first Linux machine (Ubuntu 16.04), completely green to bash/terminal, and I'm trying to get a Netgear AC600 dongle to function. What was initially happening was the driver from Netgear (rtl8812au) only supported up to kernel 4.10.x, so when I sudo apt-get upgrade-dist it update the kernel from to 4.13.x and rendered in non-functional. Now someone linked me to a repository with a more updated version of that driver and the following instructions:

$ sudo apt install build-essential git dkms
$ git clone https://github.com/gnab/rtl8812au.git
$ cd rt8812au
$ make
$ sudo cp -r rtl8812au /usr/src/8812au-4.2.2
$ sudo dkms add -m 8812au -v 4.2.2
$ sudo dkms build -m 8812au -v 4.2.2
$ sudo dkms install -m 8812au -v 4.2.2

Everything appears to have installed without errors. When I run

$ sudo dkms status

I get

8812au, 4.2.2, 4.13.0-32-generic, x86_64: installed

I've since rebooted and I still don't have wireless access and I'm pretty much back to square one. I'm not even convinced it's a driver issue anymore, please help!

  • Check if the module is loaded with lsmod | grep 8812au. If not, you may need to load the module with sudo modprobe -v 8812au. – mikewhatever Feb 18 '18 at 21:46
  • Thanks for replying It looks like it's there. It returns: **8812au** 991232 0 I ran the modprobe just for grins and it doesn't look like anything happened. Nothing output to the terminal to indicate any change and there's no wifi connection. – sonicthewhackjob Feb 18 '18 at 23:26
  • In this case, you need to provide more info for troubleshooting: askubuntu.com/questions/425155/… – mikewhatever Feb 18 '18 at 23:31
  • Is it safe to share the entire output of the file publicly? I see my mac address and ip address in here and I'm concerned with the security of it. Am I being crazy? – sonicthewhackjob Feb 18 '18 at 23:54
  • Reduct both, if you want, and whatever else you think is confidential. As long as we have the logs, it's ok, I hope. – mikewhatever Feb 19 '18 at 15:47

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.