11

Last week I replaced my Ryzen 5 1600 with a Ryzen 5 2400G. Since then I'm struggling to get the GPU working.

I've tried 16.04.3 vanilla with HWE-kernel 4.13. It works out-of-the-box, but without hardware acceleration / OpenCL (ROCm) support. I've installed the latest amdgpu-pro driver amdgpu-pro-17.50-511655 from 17-12-2017. My system won't boot with it, it hangs after entering my fulldisk encryption password.

I've also tried with the 4.15.4 and 4.16-rc1 kernel, but the AMD driver doesn't build with that kernels.

For what I've read, ROCm support for Raven Ridge doesn't exist yet.

I must say, I'm a little disappointed with AMD that they release hardware without proper software support. My APU is kinda useless now.

  • For now I'm Using Manjaro 17.1 (testing branch) with kernel 4.14-rc3 and Mesa 17.3.6. Graphics: Card: Advanced Micro Devices [AMD/ATI] Vega [Radeon Vega 8 Mobile] Display Server: x11 (X.Org 1.19.6 ) drivers: ati,amdgpu (unloaded: modesetting,radeon) Resolution: 1920x1080@60.00hz, 1680x1050@59.95hz OpenGL: renderer: AMD RAVEN (DRM 3.23.0 / 4.16.0-1-MANJARO, LLVM 5.0.1) version: 4.5 Mesa 17.3.6 – stfn Mar 8 '18 at 19:49
  • I have my home server built with Ryzen 5 2400G, currently I have installed 17.10 and running Kernel 4.15 from mainline, which is able to push my 1440p monitor at full resolution, but audio over HDMI doesn't work. However, I tried 18.04 Beta 2 yesterday (Ubuntu and Kubuntu) and it could handle resolution as well as audio over HDMI, and also tolerable video playback (it wasn't smooth but not bad as 4.15 running in 17.10 from mainline. So I think 18.04 would be best option we'd have. – Kushal Apr 8 '18 at 4:18
4

I just bought a Ryzen 5 2400G with a motherboard GA-A320-S2H and I decided to install KDE Neon based on ubuntu 16.04, it worked but it was noticeable that I was not taking advantage of the resources, I opted to try to install the proprietary drivers and I had no luck , then I put kernel 4.16, it did not work either, then install 4.17 (http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.17-rc4/) and it works in luxury. I had a small inconvenience with the network card r8168, so I installed the latest version of the driver: r8168-dkms_8.045.08-3_all.deb and everything works wonders. I can play 4k videos with CPU temperatures of 40ºC

3

This guy says it's working for him:

I tried hard to copy his setup but wasn't successful. I ended up using some proprietary driver from the AMD site which still doesn't utilize the Vega graphics on full (but helped a lot, before system was laggy, after I can play YouTube on 4K). I will do a fresh install of the system anyway as I experience system freezes (1x per hour), boot hangs every 2nd time, sleep and hibernation not working, CPU temp sensors only with a workaround. Be sure to have the latest BIOS upgrade.

This is my dump if it helps in any way:

inxi -F
System:    Host: ulkaspc Kernel: 4.15.3-041503-generic x86_64 (64 bit)
           Desktop: Xfce 4.12.3 Distro: Linux Mint 18.3 Sylvia
Machine:   Mobo: MSI model: B350M MORTAR (MS-7A37) v: 1.0
           Bios: American Megatrends v: 1.B0 date: 01/29/2018
CPU:       Quad core AMD Ryzen 5 2400G with Radeon Vega Graphics (-HT-MCP-) cache: 2048 KB 
           clock speeds: max: 3600 MHz 1: 1815 MHz 2: 2194 MHz 3: 2050 MHz
           4: 1958 MHz 5: 1714 MHz 6: 1716 MHz 7: 2079 MHz 8: 1965 MHz
Graphics:  Card: Advanced Micro Devices [AMD/ATI] Device 15dd
           Display Server: X.Org 1.18.4 drivers: ati,vesa (unloaded: fbdev,radeon)
           Resolution: 1920x1080@0.00hz
           GLX Renderer: N/A GLX Version: N/A



    RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
    Sensors:   None detected - is lm-sensors installed and configured?
    Info:      Processes: 266 Uptime: 27 min Memory: 3487.3/15042.5MB
               Client: Shell (bash) inxi: 2.2.35 
  • i installed kernel 4.16.1, and mesa 18.0 but GUI is still running in software rendering mode. do I know if apu is active? and if it is using the driver?? the output of glxinfo | grep "OpenGL version" shows mesa 18.0 – aishu Apr 12 '18 at 3:02
  • the kernel 17.rc5 is working best, including sensors and audio. with the kernel 16.3 is fine, i can run games on full details already (now 60fps before 6fps), but certainly does not squeeze all the iGPU features on full. – ulkas May 17 '18 at 8:17
3

I have AMD Ryzen 240G on Asus Prime B350M-A Motherboard, and succesfully run Ubuntu 18.04 Pre-Release. It works at full resolution on DVI, VGA and HDMI output. I don't test sound output by HDMI, but system detects 2 soundcards(?). Mayby the second one is for HDMI?

I do not modify anything and not add extra drivers/modules/firmwares and it's works quite well. I'm only noticing some issues from time to time, like hanging desktop, but it's rarelly.

3

I installed Kernel v4.16 using the .deb files here: http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.16/

I'm impressed, the APU is working very well!

In Steam I get better fps in all games than my laptop which has a dedicated GPU (GTX 860M).

2

It seems the latest fixes from AMD finally resolved all my issues. See https://cgit.freedesktop.org/~agd5f/linux/log/?h=amd-staging-drm-next For now you need to compile your own kernel or wait till those fixes land in your distribution.

1

Raven Ridge APU's are still work in progress when it comes to Linux. Unfortunately you have to use bleeding edge non-production ready software.

From testing try a Linux 4.16-rc1 or later kernel with a newer Mesa 18.1-dev + LLVM 7.0 SVN snapshot from the Padoka PPA. This should unleash the potential but it has been known to be a little unstable.

You're best getting a Bionic Beaver daily build to try out. I would expect 18.04 to be an absolute minimum Ubuntu build for these AMD APU's

1

I installed kernal 4.16-rc3 with the stable padoka PPA. It seems to detect and work half decent. I had one issue though. After installing padoka PPA for some reason I got a black screen on first boot up. So I thought, man that broke it and went to an older kernal to try to fix it. Turns out I just needed a second reboot and it was up and going. Seems to be quite stable I ran super position benchmark with no problems was between 13 and 20 FPS. Which is about all I think you can expect from a APU. Hope this info helps out someone =).

After the kernal update it did pick up the GPU part of the Ryzen 5 2400G. Also make sure your MB in advance has the memory turned up or you may be stuck at 64 MBs memory.

  • I tried different 4.16-rc kernels, but none of them got me in the desktop. It gave me black screens or graphical artifacts. – stfn Mar 8 '18 at 19:48
  • Superposition: 720p low avg 39.93fps score: 5338 1080p medium 14.38fps score: 1922 – stfn Mar 8 '18 at 20:05
1

There are NO "official" LINUX drivers available for the AMD Ryzen 2xxxG series yet - though like their previous APUs you might be able to use the iGPU for OpenCL work even though the drivers don't specifically support that iGPU.

Anything else at this point is going to be VERY iffy at best.

0

installing ubuntu 17.10.1 then updating to
https://github.com/M-Bab/linux-kernel-amdgpu-binaries kernel works.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.