2

frustrating weekend spent trying to stabilise this PC booting with 17.10 (which surely must be one of most common laptop choices for Ubuntu! so not too surprised people give up and buy MACs in the end!)

I'm posting this as more of a solution than a question, but the combination of kernel versions and cmdline options seems so delicate, am then afraid to upgrade anything.....(maybe 18.04 will be stable on this pc)

ok hardware Dell XPS 15 9560, i7-7700HQ CPU @ 2.80GHz

Bios 1.3.4,

QCA6174 802.11ac Wireless Network Adapter

Nvidia GeForce GTX 1050 Mobile

Intel graphics

dual booted with Win10 (that part runs fine)

I wanted in particular 2 things to work:

1) the machine recognises a 2nd monitor/projector (via HDMI) for presentations

2) suspend/resume works (running a VM which I don't want to reboot , reconfig etc)

I previously installed 16.04 on the machine , and although this worked fine, but neither (1) nor (2) above worked, suspend works but resume rebooted to a black screen (no messages).

so Upgraded to 17.10 (via upgrade not clean reinstall)

here the fun started, tried to install nvidia-384 via Software and Updates panel. also added sudo add-apt-repository ppa:graphics-drivers/ppa to get bigger choice in nvidia drivers (can see nvida-384, nvidia-387, nvidia-390 available)

seems cmd line acpi_rev_override=1 seems important from multiple posts but many issues not even booting to a login screen, screen flashing with text often errors seen with ACPI Exception, AE_NOT_FOUND (whenever see this it won't complete boot) screen booting to text with a few purple lines across it, but dropped back to root

Only way to solve that temporarily was to get to a root shell at boot and apt remove nvidia* apt purge nivdia*

and then boot via Recovery (cmdline added: nomodeset), which in my case always seems to require me to complete a fsck before resuming boot. (?)

then machine would boot to (Ubuntu on XOrg) , nouveau driver running for nvidia. gdm3 display manager

Also tried using Lightdm , boot ok as above (in recovery mode as ever) but no 2nd monitor or suspend/resume (suspend works, but resume brings up a black screen)

Tried more recent kernels, no luck even tried 4.15.3 and nvidia-390 as saw a post this was working, but not in my case

So , THE COMBINATION I FOUND TO WORK IS :

dpkg -l | grep nvidia

ii nvidia-384 384.111-0ubuntu0.17.10.1 amd64 NVIDIA binary driver - version 384.111

ii nvidia-opencl-icd-384 384.111-0ubuntu0.17.10.1 amd64 NVIDIA OpenCL ICD

ii nvidia-prime 0.8.5 amd64 Tools to enable NVIDIA's Prime

ii nvidia-settings 390.25-0ubuntu0~gpu17.10.1 amd64 Tool for configuring the NVIDIA graphics driver (I see I have a residual 390 driver there, doesn't seem to create issues at moment)

cat /proc/cmdline

BOOT_IMAGE=/boot/vmlinuz-4.13.0-19-generic root=UUID=30a2f3e4-58f1-49b0-91d8-1437d69d97f9 ro recovery nouveau.modeset=0 acpi_rev_override=1

(I have to pass via 4.13.0.9-generic Recovery mode though, edit cmdline with above, run fsck, resume boot)

I seem to have the nouveau driver still loaded

lsmod | grep nouveau

nouveau 1638400 0 mxm_wmi 16384 1 nouveau ttm 94208 1 nouveau

i2c_algo_bit 16384 2 nouveau,i915

drm_kms_helper 167936 3 nouveau,i915,nvidia_drm drm 356352 13 nouveau,i915,ttm,nvidia_drm,drm_kms_helper wmi 24576 4 dell_wmi,wmi_bmof,mxm_wmi,nouveau video 40960 4 dell_wmi,dell_laptop,nouveau,i915

Using gdm3 (3.26.1-3ubuntu3)

in /etc/gdm3/custom.conf

#WaylandEnable=false

dpkg -l | grep "4.13.0-19"

ii linux-headers-4.13.0-19 4.13.0-19.22 all Header files related to Linux kernel version 4.13.0

ii linux-headers-4.13.0-19-generic 4.13.0-19.22 amd64 Linux kernel headers for version 4.13.0 on 64 bit x86 SMP

ii linux-image-4.13.0-19-generic 4.13.0-19.22 amd64 Linux kernel image for version 4.13.0 on 64 bit x86 SMP

ii linux-image-extra-4.13.0-19-generic 4.13.0-19.22 amd64 Linux kernel extra modules for version 4.13.0 on 64 bit x86 SMP

this combination boots, recognises a connection of external monitor (plug in and out hdmi cable after boot is ok). I noticed if I insist on Mirror mode the Gnome settings drivers crashed once.
suspend/resume ok (Alt-power-down to suspend) (I manually suspend, I don't close the lid, fear of it not suspending and overheating)

power consumption seems a bit high still (fan running low often)

Anyway, good luck to all 9560 owners out there.....

if anyone out there has other combinations working .....

  • You posted your diary but didn't ask a question. The format for this website is to ask a question with a title like "Why is suspend/resume broken?". Then below you answer your own question and insert your diary. – WinEunuuchs2Unix Feb 19 '18 at 15:13
1

I manage to resolve your thing 2 by changin the additional driver from "X.org X server*" to "NVIDIA binary driver*".

Dashboard > Additional Drivers > select driver..

reboot

Unfortunatelly external monitors do not work for me either. (edit: Works now)

System properties

Hardware: Dell XPS 15 9560

Processor: Intel® Core™ i7-7700HQ CPU @ 2.80GHz × 8

Graphics: GeForce GTX 1050/PCIe/SSE2

Driver: nvidia-384

OS: Ubuntu 16.04 (no dual boot)

Kernel: 4.13.0-32-generic

BIOS: 1.6.2

External monitor

I was able to get my external monitor working aswell for:

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.