1

I can't connect to WiFi from my notebook. It was working fine for a long time until recently. There have been updates to linux-firmware.

I didn't notice it right away because I usually have my notebook connected by Ethernet - which works fine.

It seems like something is wrong at the notebook end. How do I rule out a hardware failure?

Details:

Analyser script output

I finally remembered to looked in dmesg and found that

It was trying to load iwlwifi-7265D-19.ucode or iwlwifi-7265D-18.ucode, but I only have 10,12,13,16,17,21,22,27,29

So I tried (as a stopgap measure)

sudo ln -sf iwlwifi-7265D-17.ucode iwlwifi-7265D-19.ucode

which got rid of the error:

bigbird@sananda:/lib/firmware$ dmesg -T | grep wifi
[Sun Feb 18 01:48:52 2018] iwlwifi 0000:07:00.0: loaded firmware version 17.352738.0 op_mode iwlmvm
[Sun Feb 18 01:48:53 2018] iwlwifi 0000:07:00.0: Detected Intel(R) Dual Band Wireless AC 7265, REV=0x210
[Sun Feb 18 01:48:53 2018] iwlwifi 0000:07:00.0: L1 Enabled - LTR Enabled
[Sun Feb 18 01:48:53 2018] iwlwifi 0000:07:00.0: L1 Enabled - LTR Enabled
[Sun Feb 18 01:48:53 2018] iwlwifi 0000:07:00.0 wlp7s0: renamed from wlan0
bigbird@sananda:/lib/firmware$

But didn't fix the problem.

bigbird@sananda:/lib/firmware$ rfkill unblock wifi
bigbird@sananda:/lib/firmware$ rfkill unblock wlan
bigbird@sananda:/lib/firmware$ rfkill list
0: Toshiba Bluetooth: Bluetooth
        Soft blocked: no
        Hard blocked: no
1: hci0: Bluetooth
        Soft blocked: no
        Hard blocked: no
2: phy0: Wireless LAN
        Soft blocked: no
        Hard blocked: yes
bigbird@sananda:/lib/firmware$

I found this, but don't really understand it:

https://wireless.wiki.kernel.org/en/users/drivers/iwlwifi/core_release

There are a whole lot of "end of life" notices there, but this notebook is only a few years old.

Hardware:

Toshiba Satellite S55 C5274

kubuntu 16.04

Technicolor Gateway TC8717 (BATC8717T V4)

My smartphone can access the WiFi fine, so it's up.

I can access my gateway via Ethernet cable and it looks fine.

Running

rfkill unblock wifi

or wlan, with or without sudo only affects the soft block.

The wifi toggle on my keyboard turns the soft block on and off, but leaves the hard block in place.

I do not have a firewall running on my notebook and I just have one totally external IP blocked using iptables.

sudo lshw

shows:

        *-pci:1
             description: PCI bridge
             product: Wildcat Point-LP PCI Express Root Port #3
             vendor: Intel Corporation
             physical id: 1c.2
             bus info: pci@0000:00:1c.2
             version: e3
             width: 32 bits
             clock: 33MHz
             capabilities: pci normal_decode bus_master cap_list
             configuration: driver=pcieport
             resources: irq:43 memory:b3300000-b33fffff
           *-network DISABLED
                description: Wireless interface
                product: Wireless 7265
                vendor: Intel Corporation
                physical id: 0
                bus info: pci@0000:07:00.0
                logical name: wlp7s0
                version: 61
                serial: dc:53:60:cb:27:17
                width: 64 bits
                clock: 33MHz
                capabilities: bus_master cap_list ethernet physical wireless
                configuration: broadcast=yes driver=iwlwifi driverversion=4.4.0-112-generic firmware=17.352738.0 latency=0 link=no mu$
                resources: irq:53 memory:b3300000-b3301fff

bigbird@sananda:~/bin$ sudo ip -a link

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT group default qlen 1
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: enp8s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP mode DEFAULT group default qlen 1000
    link/ether 54:ab:3a:0d:4f:a4 brd ff:ff:ff:ff:ff:ff
3: wlp7s0: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN mode DEFAULT group default qlen 1000
    link/ether dc:53:60:cb:27:17 brd ff:ff:ff:ff:ff:ff
bigbird@sananda:~/bin$
5
  • Is there any change if you do: sudo modprobe -r toshiba_acpi && sudo rfkill unblock all? – chili555 Feb 20 '18 at 1:16
  • @chili555 Thanks, but that appears to have no effect. – Joe Feb 20 '18 at 10:51
  • How about: sudo modprobe -r toshiba_acpi It may not be present if you removed it above and haven't rebooted. Just continue: sudo modprobe toshiba_acpi disable_hotkeys=Y Now does the wifi toggle work as expected? If so, we'll make it permanent. – chili555 Feb 20 '18 at 14:47
  • Both commands ran without complaint. rfkill list still shows hard block on phy0:. So, no noticeable effect. Ran rfkill unblock {wifi,wlan}. Should that have worked? – Joe Feb 23 '18 at 0:18
  • Aside from taping a pin on the wireless card itself, I have no other suggestions. forum.notebookreview.com/threads/… ubuntuforums.org/showthread.php?t=2358374 – chili555 Feb 23 '18 at 0:43
0

Finally got WiFi to work - using an external adapter! Only took eleven months.

First, I tried a Penguin PAU06 adapter, but even with their support, I couldn't get it to work.

I just bought another WiFi adapter from ThinkPenguin and at first, that didn't work either. But they had instructions on how to disable the internal WiFi card (inside the notebook) and that's what made the ThinkPenguin adapter work. It also made the Panda work.

The trick is:

Find its ID (I'm not sure what type of ID it is. I think it's a hardware device ID):

bigbird@sananda:~$ realpath /sys/class/ieee80211/phy0 | cut -f 6 -d '/'
0000:07:00.0

And then create a udev rule that disables it and put it in /etc/udev/rules.d/81-wireless-pci.rules:

ACTION=="add", KERNEL=="0000:07:00.0", SUBSYSTEM=="pci", RUN+="/bin/sh -c 'echo 1 > /sys/bus/pci/devices/0000:07:00.0/remove'"

Note that the ID gets inserted in two places in the above command. The actual ID will probably be different on other systems.

I'm not sure if it was necessary, but I rebooted after adding the above file.

Since finding USB WiFi adapters that work on Linux is apparently worse than getting video cards to work, here are the two models that now work on my system:

Panda PAU06 - N300
ThinkPenguin TPE-N150USB - N150

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.