8

Following instructions here:

https://docs.npmjs.com/getting-started/installing-node

I get the following results:

npm -v
3.10.10

npm install npm@latest -g

npm -v
3.10.10

According to the link above, the current stable version of npm is 5.6.0.

Edit: For context, the reason I am trying to upgrade Node and npm is because I am installing UIkit and their instructions said "Use Node.js version 8.2.0 or higher".

Edit: I don't know if safe/best practise, but I did the following (there's a myriad of solutions out there, many seemed over complicated and not authoritative)

sudo apt-get purge --auto-remove nodejs

Then followed instructions from:

https://nodejs.org/en/download/package-manager/#debian-and-ubuntu-based-linux-distributions

and ran:

curl -sL https://deb.nodesource.com/setup_8.x | sudo -E bash -
sudo apt-get install -y nodejs

Now I get desired versions:

npm -v
5.6.0

node --version
v8.9.4

closed as off-topic by Ketan Patel, N0rbert, Eric Carvalho, vanadium, Zanna Oct 17 '18 at 20:15

This question appears to be off-topic. The users who voted to close gave these specific reasons:

  • "This describes a problem that can't be reproduced, that seemingly went away on its own or was only relevant to a very specific period of time. It's off-topic as it's unlikely to help future readers." – Eric Carvalho, Zanna
  • "This question is specific to an end of life Ubuntu release. These are no longer supported and are therefore off-topic here. To upgrade, see: How to install software or upgrade from old unsupported release?" – Ketan Patel, N0rbert, vanadium
If this question can be reworded to fit the rules in the help center, please edit the question.

Browse other questions tagged or ask your own question.