1



I've been trying to install MATLAB 2017a on my Ubuntu 17.10. I've had encountered several problems while installing, most importantly not being able to install as root, which was solved by another ask ubuntu post asking me to use

xhost si:localuser:root

and beginning the sudo operation as

sudo sh ./install -javadir /usr/lib/jvm/java-8-openjdk-amd64/jre/.

However, while the installation begins, I'm being thrown another error "archive is not a zip file". I've attached the image for your references, Matlab Installation Error.

Any help would be really appreciated thanks.

3
  • 2
    Hi Vijey, could you please post the contents of /tmp/mathworks_root.log? Also, why do you want to install as root rather than as a normal user?
    – dja
    Commented Feb 18, 2018 at 0:41
  • Here is the link to the log file "drive.google.com/open?id=1ScJa3Wn2kSiae5yC1RSwauc8mC1P1LbZ". I'm trying to install as root, as it requires root permission to install its files in usr/local directory.
    – Vijey
    Commented Feb 18, 2018 at 1:03
  • Looking at au.mathworks.com/matlabcentral/answers/… - have you tried redownloading the installer? The other thing you could try is running 'sudo chmod 777 /usr/local' but I wouldn't really recommend this on your primary system...
    – dja
    Commented Feb 18, 2018 at 1:20

0

You must log in to answer this question.

Browse other questions tagged .