So I accidentally did something very dumb today, running sudo apt-get remove dbus instead of running sudo apt-get remove python-dbus. This led to my dpkg being broken and me getting a 'failed to start session' error when I try to log in. Going to recovery mode, I've tried to fix broken packages, but I get an error from that saying that it can't import distupgrade from python3/dist-packages. When I try to run the networking option in the recovery menu to try to reinstall some of the packages I removed, it hangs on "Reached Target Sound Card". I am completely at loss for what to do at this point, I've tried almost everything I can think of. Any help is appreciated! Thank you.

  • I'm not great at Linux, my advice is to fresh install if you don't have anything crucial on your computer. If you do, try backing up your files on a USB, then fresh install and copy over the files you need from that USB. Feb 18, 2018 at 0:52
  • Yeah, the first thing I did was back up my files. The only thing is this is a pretty customized install and it would be easier to fix it even if it takes a few hours than to get everything set up again.
    – Itaque
    Feb 18, 2018 at 2:38

1 Answer 1


Use following commands :

# apt-get purge dbus

After that :

# apt-get install ubuntu-desktop
  • When I run this I get a bunch of failed to fetch ppas because I'm not online. That's part of my problem.
    – Itaque
    Feb 17, 2018 at 23:44

Not the answer you're looking for? Browse other questions tagged or ask your own question.