1

Everything went well during installation, I created a 50GB partition for Linux, chose the "Install alongside windows 10" Option, because "something else" did not work for me before. However, after rebooting, it boots directly into Windows 10. I've tried going to the BIOS to change the BOOT order but Ubuntu doesn't even show up there, I tried opening the boot menu (pressing f12 key on my laptop during reboot) and the only option there is windows boot manager, which also boots to win 10.

I tried boot-repair and it said it repaired succesfully but the problem still remains. Here's the report: http://paste.ubuntu.com/p/zkWJMFpJwb/

My computer runs on UEFI and I've already disabled secure boot. I also tried Legacy boot but no luck there either.

Please help, I can't figure out how to get the Grub menu, so I can actually choose which system I want to boot.

marked as duplicate by Byte Commander, David Foerster, George Udosen, Eric Carvalho, Charles Green Feb 18 '18 at 15:47

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Especially check out the "TROUBLESHOOTING" section in the top voted answer to the question linked above. – Byte Commander Feb 17 '18 at 22:55
  • What is your boot priority list in the bios ? – An0n Feb 17 '18 at 23:13
  • Acer has a unique requirement of setting an UEFI password and enabling "trust" on the .efi boot file for ubuntu/grub. Details askubuntu.com/questions/771455/… You also installed grub in BIOS boot mode. Do not use BIOS/Legacy/CSM boot mode, only UEFI. – oldfred Feb 18 '18 at 0:12
1

If it's an Acer computer, you have to follow the procedure here: Acer Aspire E15 will not dual boot If Ubuntu is already installed, you should just do steps from 2 to 16 (not all of them, only what's in your BIOS and is different from what's written there), and, most important, steps from 34 to 43. There is a small mistake in step 40, you have to write grubx64efi without the dot.

You should also do this to make the touchpad work, if it's a laptop Just installed ubuntu on an acer latop and now the touchpad wont work. How do i fix this?

0

Install GRUB on /dev/sda instead of /dev/sda(x) like this :

sudo grub-install /dev/sda

Normally this should fix your problem, if not you can use bootrepair again. Also you can use GRUB Customizer to edit the bootloader.

It should be like this : enter image description here

  • Looking at the provided boot-repair output, this is already the case. It isn't that easy any more in times of UEFI and Win 10. – Byte Commander Feb 17 '18 at 22:57
  • As far as i can see, he has /boot on a vfat instead of ext4 also grub is on sda6 instead of sda. Also i dont see a root mount point. – An0n Feb 17 '18 at 22:59
  • No, it says ` => Grub2 (v1.99-2.00) is installed in the MBR of /dev/sda` and sda1 is the EFI partition, whereas sda6 is Ubuntu's root partition containing its grub.cfg config file. That is all fine. – Byte Commander Feb 17 '18 at 23:03
  • Also i dont think this is correct : ` echo ; echo Grub is now loading the Windows EFI Boot Manager chainloader $efibootmgr `so i still recommend to reinstall the bootloader on /dev/sda – An0n Feb 17 '18 at 23:12
  • That is completely fine, it's part of the definitions for the menu entries for Windows inside GRUB. Your screenshots show the configuration for a system in Legacy BIOS mode, but the OP obviously has an UEFI system. Please don't blindly apply methods for one onto the other, they are inherently different! – Byte Commander Feb 17 '18 at 23:40

Not the answer you're looking for? Browse other questions tagged or ask your own question.