1

I've reviewed and tried the suggestions in all the linked answers but have not been able to find and enable the wifi (and bluetooth) in my AZW Z83V miniPC (Intel ATOM 64bit) which is now solely running ubuntu 16.04 (kernel 4.13)
The WIFI/BT worked under Windoze 10 as initially configured. In the bios setup -> boot screen it shows Broadcom Wifi Select with options AP6255 or AP6212. I've tried either without linux being able to find them. These indicate that the hardware/firmware is AMPAK and so reference to Broadcom numbers in answers do not equate to me. I'm not looking for a silver-bullet just a logical way of troubleshooting this. Thanks

created wireless-info.txt as directed with these results: https://paste.ubuntu.com/p/jknTf5XFwD/

dmesg | grep -i sdio; ls /sys/firmware/efi/efivars | grep nvram
[    3.010118] mmc1: new ultra high speed SDR104 SDIO card at address 0001
[    6.941546] Bluetooth: Generic Bluetooth SDIO driver ver 0.1
[    7.174603] brcmfmac mmc1:0001:1: Direct firmware load for
brcm/brcmfmac43455-sdio.txt failed with error -2
[   10.180311] brcmfmac: brcmf_sdio_htclk: HT Avail timeout (1000000): clkctl 0x50
[   11.188316] brcmfmac: brcmf_sdio_htclk: HT Avail timeout (1000000): clkctl 0x50

I decided to start fresh - cleared all partitions and renewed - Installed fresh Ubuntu 17.10 instead of the LTS - No difference yet but the last edit dmesg output is from 17.10

Feb 23/18 nothing found in my research and tries yet - Seems like this is problem during bootup where grub2 doesn't detect the hardware as it's then not detected (or correctly detected) by software requiring it. Is there a way of seeing what grub2 detects for hardware before bootup is handed off to ubuntu?

  • 1
    Start here: askubuntu.com/questions/425155/… – mikewhatever Feb 17 '18 at 19:33
  • Please edit to include results from terminal for dmesg | grep -i sdio; ls /sys/firmware/efi/efivars | grep nvram – Jeremy31 Feb 18 '18 at 15:17
  • Please use the { } button above the edit window to format pasted output. – user68186 Feb 20 '18 at 16:39
1

You are missing firmware and it is normally made by doing a

sudo cp /sys/firmware/efi/efivars/nvram-74b00bd9-805a-4d61-b51f-43268123d113 /lib/firmware/brcm/brcmfmac43455-sdio.txt
But if the nvram file doesn't exist we can try searching google for one that might work We can try one file found while reading https://patchwork.kernel.org/patch/9517201/

wget https://github.com/khadas/android_hardware_amlogic_wifi/raw/b6709758755568e4a0ff6e80993be0fc64c77fb9/bcm_ampak/config/6255/nvram.txt
sudo cp nvram.txt /lib/firmware/brcm/brcmfmac43455-sdio.txt

Reboot and see if it works now

  • Feedback to Jeremy31 - sudo cp /sys/firmware.... reported no such file but the second suggestion wget https:/github to try add brcmmac43455-sdio.txt.....after reboot enabled WIFI which not only gave me insight into how to diagnose (my question) but provided a solution. – Gord-NB Feb 24 '18 at 20:48
  • Great as these Broadcom SDIO wifi can be particular about that nvram file and just having one from the same model card doesn't always work – Jeremy31 Feb 24 '18 at 20:53

protected by N0rbert Jan 27 at 20:55

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.