I've installed the last update from yesterday and today I logged in and no terminal, no dash, launcher, nothing is working. I've tried the solutions from here:

Ubuntu 16.04 Jan 3 2018 update causing screen/access issues

and also tried this:

export DISPLAY=:0

end enabled Unity and reboot from terminal but I still not working. When I log in guest session it's normal. Is there a working solution for that? Thanks.

  • I tried to install unity and enabled it without success. I had to create another user with sudo privileges
    – ivva
    Feb 17, 2018 at 16:34

1 Answer 1


This doesn't sound like the bug linked in the OP's question or the close candidate in the comments section: 2/15/18 compiz update broke unity. It sounds more like this common problem: Unity doesn't load, no Launcher, no Dash appears

This is especially true due to comments in deep within my proposed link stating the guest session works perfectly just not the normal user. The OP here has same scenario.

Try the simple solution there by opening a terminal and typing:

rm -rf ~/.config/compiz-1/compizconfig/*
sudo reboot

Some users say it works right away while someone else says the reboot is necessary.

  • This worked for me after the reboot - thank you very much
    – NickT
    Mar 9, 2018 at 11:50
  • @NickT Thank you for your feedback. There are many different things people are trying and it's nice to get confirmation this one worked in your case. Mar 9, 2018 at 11:51
  • This also worked for me after reboot. I had system errors referencing compiz, this brought back my launcher and menu bar. Apr 5, 2018 at 7:50
  • Happened to me today (July 2019) and I can confirm this worked for me perfectly after trying several other suggestions with no success :D
    – DarkCygnus
    Jul 9, 2019 at 17:34

Not the answer you're looking for? Browse other questions tagged or ask your own question.