0

I was trying to upgrade 14.04 when I started to get dependencies error.

I have read and tried many things to fix the problem, but I always end up getting the error for any of the commands such as:

$ sudo apt-get install --fix-broken --fix-missing

or

$ sudo apt-get update (or upgrade)  

or

$ sudo apt-get -f install

also I have tried commands such as:

$ sudo apt-get --reinstall install locales

Or

$ Sudo apt-cache policy libc6* locale

Or

$ sudo dpkg --configure -a

$ sudo apt-get install --fix-broken --fix-missing

Gives:

(Reading database ... 319648 files and directories currently installed.)
Preparing to unpack .../libc-bin_2.26-0ubuntu2_amd64.deb ...
dpkg: error processing archive /var/cache/apt/archives/libc-bin_2.26-0ubuntu2_amd64.deb (--unpack):
 triggers ci file contains unknown directive `interest-await'
Errors were encountered while processing:
 /var/cache/apt/archives/libc-bin_2.26-0ubuntu2_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
0

Upgrading 14.04 to 17.10 isn't supported.

The package you are trying to install requires a more recent version of dpkg than the one you have. Try to download the .deb package from https://packages.ubuntu.com/artful/dpkg and install it using dpkg:

sudo dpkg -i dpkg_1.18.24ubuntu1_amd64.deb

(you may need to replace the file name and path). Maybe that works.

Consider doing a fresh install of 17.10.

  • Thank you. Have been trying for sometime. Cannot install any package. Broken software system. – Mike Feb 17 '18 at 2:31
  • $ sudo dpkg -i dpkg_1.18.24ubuntu1_amd64.deb dpkg: error processing archive dpkg_1.18.24ubuntu1_amd64.deb (--install): cannot access archive: No such file or directory Errors were encountered while processing: dpkg_1.18.24ubuntu1_amd64.deb – Mike Feb 17 '18 at 2:40
  • $ sudo dpkg -i dpkg_1.18.24ubuntu1_amd64.deb dpkg: error processing archive dpkg_1.18.24ubuntu1_amd64.deb (--install): cannot access archive: No such file or directory Errors were encountered while processing: dpkg_1.18.24ubuntu1_amd64.deb – Mike Feb 17 '18 at 2:40
  • packages.ubuntu.com/artful/dpkg Resolving packages.ubuntu.com (packages.ubuntu.com)... 91.189.94.203 Connecting to packages.ubuntu.com (packages.ubuntu.com)|91.189.94.203|:443... connected. HTTP request sent, awaiting response... 200 OK Length: unspecified [text/html] Saving to: ‘dpkg’ [ <=> ] 12,914 --.-K/s in 0.008s 2018-02-16 18:32:09 (1.48 MB/s) - ‘dpkg’ saved [12914] – Mike Feb 17 '18 at 2:46
  • now I am back to the worst situation. libc-bin : Depends: libc6 (< 2.20) but 2.26-0ubuntu2 is to be installed libc-dev-bin : Depends: libc6 (< 2.20) but 2.26-0ubuntu2 is to be installed libc6 : Breaks: locales (< 2.26) but 2.13+git20120306-12.1 is to be installed libc6:i386 : Breaks: locales (< 2.26) but 2.13+git20120306-12.1 is to be installed libc6-dbg : Depends: libc6 (= 2.19-0ubuntu6.6) but 2.26-0ubuntu2 is to be installed – Mike Feb 17 '18 at 3:27

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.