0

Network manager wasn't applying the DNS servers that I entered using "Edit Connections" -> "Wired Connection 1" -> IPv4 Settings -> Switch to "Automatic (DHCP) addresses only -> entered in DNS servers

dig @10.1.0.16 internal.address works just fine, gives me what's expected.

editing resolv.conf doesn't seem to do the trick, and just gets overwritten anyways.

nmcli shows that the correct DNS servers are being used

systemd-resolve --status shows the DNS servers as expected

again, digging the DNS servers works great.

I've tried switching to dnsmasq as a workaround, which has probably just added to my confusion. I'm not even sure what to provide as far as logs go. What do you guys need to help?

  • Have you tried disabling the dnsmasq line in /etc/NetworkManager/NetworkManager.conf? Just comment it out with a # in front of it. Secondly, if you want stuff to stay in /etc/resolv.conf you edit the file /etc/resolvconf/resolv.conf.d/original then when resolvconf -u is ran the lines are added automatically to /etc/resolv.conf – Terrance Feb 16 '18 at 20:57
  • actually you may be on to something with that. the link at /etc/resolvconf/resolv.conf.d/original points to ../run/systemd/resolve/stub-resolv.conf which doesn't exist – Daniel Agans Feb 16 '18 at 21:28
  • I went ahead and added the symlink and put my DNS servers into the stub-resolve.conf then restarted network-manager but unfortunately behavior is the same. I can resolve external but not internal resources. – Daniel Agans Feb 16 '18 at 21:37
  • What version of Ubuntu are you using? – Terrance Feb 16 '18 at 21:39
  • 17.10 it appears – Daniel Agans Feb 17 '18 at 5:25
0

On the IPV4 tab try switching automatic DHCP to Manual so you will be using the values you enter for the DNS server IP addresses,

Here are instructions for Ubuntu 16. Should work the same for V14 and V17

  • after making this change the behavior is the same – Daniel Agans Feb 16 '18 at 20:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.