0

I'm new to Ubuntu, and I installed IntelliJ, Android Studio and Unity3D

Now Unity3D used a .deb file and thus is listed in the dpkg and apt, and Android Studio, while not coming in a deb file, created a shortcut into /usr/share/applications, so I get how the x11 and Unity (the desktop GUI) is able to show it when I search for it. But I can search for IntelliJ, and the search bar does show it as an application, but I was not able to find it either in apt nor the /usr/share/applications folder, so I'm simply wondering how the GUI knows that it is installed.

  • 1
    Putting "solved" in the title is not needed. Instead, mark your answer as "Accepted", and that will effectively mark the question as "solved". You may have to wait a few days before you can accept the answer. – wjandrea Feb 16 '18 at 20:49
  • I "cannot accept my own answer" smh – Alex Gagne Feb 18 '18 at 20:59
  • Oh well now I can for some reasons. I really could not accept my own answer – Alex Gagne Feb 19 '18 at 3:34
0

There are (at least) two applications folder that X11 (I assume) is looking into: /usr/share/applications AND ~/.local/share/applications. I found the shortcut in ~/.local/share/applications.

|improve this answer|||||
  • So the shortcut was in ~/.local/share/applications? Just clarifying. – wjandrea Feb 16 '18 at 20:54
  • Indeed it was, I checked – Alex Gagne Feb 18 '18 at 21:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.