1

I tried to install xdman using

sudo add-apt-repository ppa:noobslab/apps 
sudo apt-get update
sudo apt-get install xdman

but I can't download it; I get this:

E: Could not get lock /var/lib/dpkg/lock - open (11: Resource temporarily unavailable)
E: Unable to lock the administration directory (/var/lib/dpkg/), is another process using it?

I get the same error if I try to install anything else.

After resolving that, I now get the error

E: unable to locate package xdman

this is the new error I got

marked as duplicate by pomsky, karel, Eric Carvalho, Zanna, user535733 Feb 19 '18 at 12:28

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • The error as it says in temporary. most likely you system is checking for updates and 'beat' you to the lock (first in is first served..) Check you don't have a question waiting, try again or better yet wait a few minutes and then try. You can lock it yourself if you have one terminal doing updates, and then on another terminal try to 'update' a second time, but most likely it's just auto-updates. – guiverc Feb 16 '18 at 6:51
  • i could download anything i want before i use sudo add-apt-repository ppa:noobslab/apps after that i could download nothing. – mehdi rafiee Feb 16 '18 at 6:54
  • I know this sounds like a cop-out, but something looks flaky with your network connection. If you have the ability, I would try a different connection (coffee shop, friends wifi, etc) just to compare.. – dpb Feb 18 '18 at 20:07
2

I too have encountered this issue many times in my intial days of using Ubuntu (or similar distros)

To resolve your new issue, follow the steps as given below:

  • Either download the setup file from this link - Xdman Setup files OR you can also use the wget command as - wget https://sourceforge.net/projects/xdman/files/xdm-setup-x64.tar.xz (if you are downloading x64 architecture)

  • Once you have the setup file in tar.xz format, proceed to the next step of extraction. The command is - tar -xvf xdm-setup-x64.tar.xz

The step wise installation goes as follows:

$ wget https://sourceforge.net/projects/xdman/files/xdm-setup-x64.tar.xz

$ tar -xvf xdm-setup-x64.tar.xz
  • As you execute the command, you can find the extracted folder in your home directory.

  • Right click on folder name xdman-setup and select Open in terminal.

  • Once you open the folder in terminal, simply enter - sudo ./install.sh to execute the script as root.

As soon as you execute the above command, you will see installation process will initiate on the terminal itself:

$ sudo ./install.sh
sudo: unable to resolve host mann
[sudo] password for tecjunkie: 
rm: cannot remove '/opt/xdman': No such file or directory
Initializing setup...
88939+0 records in
177878+0 records out
91073536 bytes (91 MB, 87 MiB) copied, 0.282047 s, 323 MB/s
Extracting files...
Installing...
Unpacking  /opt/xdman/jre//lib/charsets.pack...
Unpacking  /opt/xdman/jre//lib/ext/localedata.pack...
Unpacking  /opt/xdman/jre//lib/jsse.pack...
Unpacking  /opt/xdman/jre//lib/rt.pack...
Finishing installation...
Xtreme Download Manager installed successfully
You can start XDM from start menu, or type xdman in terminal as non root user

Once done, you can run xdman either from the start menu or you can also type xdman in the terminal.

As soon as you start, it will ask you to choose your browser to help you install add-on for xdman. Just follow in the process and you will then be able to download videos at ease.

  • it realy helped me thanks but when i try $ ps -A | grep apt it shows me nothing – mehdi rafiee Feb 16 '18 at 6:58
  • Glad to know it worked for you. Mark the asnwer as correct solution so that even others can benefit from it. Thanks. – Manu Mathur Feb 16 '18 at 7:01
  • heres another problem : sudo apt-get install xdman Reading package lists... Done Building dependency tree Reading state information... Done E: Unable to locate package xdman why does it says unbale to locate package xdman ? again it says the same thing when i want to install steam or telegram or chrome .. anything – mehdi rafiee Feb 16 '18 at 7:08
  • can you please share a screenshot. Try the second answer in this link - askubuntu.com/questions/540054/… The first answer is what you originally tried. May be the second answer given in the link resolves this issue. – Manu Mathur Feb 16 '18 at 7:12
  • i.stack.imgur.com/plarC.png – mehdi rafiee Feb 16 '18 at 7:41

Not the answer you're looking for? Browse other questions tagged or ask your own question.