I have a joystick(img) with device id

0079-0006-DragonRise Inc. Generic USB Joystick

I would like use it in my Ubuntu 16.04 system. So I tried to install joystick and jscalbrator to confiure the device.

Following commands where used:

sudo apt install joystick

Tried to test it with


Output :

The program 'jstest-gtk' is currently not installed. You can install it by typing:sudo apt install jstest-gtk

I tried to install it.

Output image 1


sudo apt-get install jscalibrator

Output image 2

I tried antimicro,but got the error : E: Unable to locate package antimicro And

sudo apt-get install xboxdrv


sudo xboxdrv –detach-kernel-driver

Error : -- [ ERROR ] ------------------------------------------------------ No Xbox or Xbox360 controller found

Later used lsusb to find my device and got Bus 002 Device 009: ID 0079:0006 DragonRise Inc. PC TWIN SHOCK Gamepad lsusb -vd 0079:0006 Output:

Output image 3

Output image 4


xboxdrv --debug --device-by-id 0079:0006 --type xbox360 --detach-kernel-driver

Output image 5

jscal -c /dev/input/js0


Output image 6

Output image 7

I dont know what else to do.

PS:Hope I provided all the necessary information regarding my problem.


The following worked for me :

modprobe -r xpad 
modprobe xpad

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.