2

Here is the problem, today i started updating my ubuntu 16.04 laptop, to my surprise i got some packages that are marked as "Kept back", here are these packages

compiz compiz-core compiz-gnome compiz-plugins-default libcompizconfig0  libdecoration0

After some googling i tried to run sudo apt-get dist-upgrade i got some info on the kept back packages, like how many are there, how much memory will they use, the standard stuff and after that, the surprise i got

The following packages will be REMOVED:  ubuntu-desktop unity unity-tweak-tool

is this normal? i mean uninstall ubuntu-desktop unity ??? wont that uninstall my DE ???

3
  • I'm having the same problem. I decided not to proceed with the update. There's something wrong going on... – Felipe Feb 15 '18 at 21:53
  • This happened to me as well. Unity and ubuntu-desktop were removed. – Organic Marble Feb 15 '18 at 23:32
  • It is not normal. You are right. See askubuntu.com/questions/1006621/… for how to revert back. – user68186 Feb 16 '18 at 3:58
2

You were more observant than me, as I just happily removed Unity using apt-get dist-upgrade! Sure enough it was gone after I rebooted, and apt-get install -f unity was also rejected. I had to install aptitude then aptitude install unity, which undid the damage caused by dist-upgrade.

dist-upgrade is still wanting to remove unity though.

2
  • I wasn't able to reinstall unity due to a missing dependency. – Organic Marble Feb 15 '18 at 23:33
  • To conclude, the aptitude solution to this problem which I promoted, has had no knock-on effects for me and now dist-upgrade has finally happily ran and updated without needing to remove anything. – user795750 Feb 17 '18 at 21:18
0

I had the same problem. The following steps fixed it for me:

  1. Right-click on desktop and open a terminal
  2. Execute sudo aptitude install unity
  3. Answer the first question with "no"
  4. Then confirm the downgrade of packages
  5. After the operation finished, reboot with sudo reboot
0

Hmm what ever was the problem is now resolved. Today i was able to upgrade with no issues.

1
  • I'm glad they fixed this bug in one day. – WinEunuuchs2Unix Feb 16 '18 at 13:17

Not the answer you're looking for? Browse other questions tagged or ask your own question.