3

Today I ran

sudo apt-get update
sudo apt-get upgrade

After the upgrade, my HP EliteBook 840 G1 was stuck in a bootloop, with an error message appearing for the blink of an eye:

System BootOrder not found. Initializing defaults.

Creating boot entry "Boot000B" with label "ubuntu" for file "\EFI\ubuntu\shimx64.erf"

Reset System

Luckily, I'm still able to boot into Ubuntu by using the manual boot device option of my UEFI BIOS, where I can select "ubuntu" and boot it. However, if I'm advising my BIOS to use "OS Boot Manager", the error message appears again.

Is there a way to fix this and make my Notebook boot normally again, instead of having to boot up Ubuntu manually?

  • Have you managed to solve your problem? Im having the same issue – svlada Mar 12 '18 at 18:29
  • Not exactly solved. After trying the Ubuntu version 17.10 und 16.04 LTS from the website and still suffering from the very same problem, I used an old version of 17.10 from December (which I had still on my disk) and the issue was resolved. However, installing updates will only bring it up again. The only updates I can install without the error occurring again are security updates via sudo unattended-upgrades -d . – Xeno Mar 14 '18 at 7:48
  • I've managed to boot into Ubuntu/Windows, by booting Ubuntu from LiveCD and then manually setting boot order through efibootmanager. Now I have issue that boot order is not preserved. – svlada Mar 14 '18 at 9:33
  • I have seen older UEFI firmware that always looks for Windows boot loader before any others regardless of Boot Order. Find a Windows method to change the Boot Order and see if it stays after power cycle. – rcpa0 May 6 '18 at 17:37
0

For people still finding this question: It was answered in a later thread: system bootOrder not found

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.