2

Our wifi password at work recently changed. I edited the old connection to have to new password by

$ nmcli connection edit "Internet"
$ set wifi-sec.psk <password>
$ save persistent
$ activate

Everything was fine for about five minutes. but after that the connection went down. I can re start it but it continues to go down every 1-5 minutes or so (I had to restart wifi four times while typing this question). I sometimes get an error message when trying to restart the connection but even when the error occurs the connection will successfully restart.

$ nmcli connection up "Internet" 
Passwords or encryption keys are required to access the wireless network 'Internet'.
Warning: password for '802-11-wireless-security.psk' not given in 'passwd-file' and nmcli cannot ask without '--ask' option.
Error: Connection activation failed.

I've tried resetting the password for the connection again, and removing and recreating the connection all with the same results.

Is this an nmcli issue or a driver issue or something else?

Computer is a Dell Latitude E6230, Ubuntu version is 16.04.3, lshw gives:

description: Wireless interface
       product: Centrino Advanced-N 6205 [Taylor Peak]
       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:02:00.0
       logical name: wlp2s0
       version: 34
       serial: 84:3a:4b:9c:b5:f0
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=iwlwifi driverversion=4.4.0-112-generic firmware=18.168.6.1 ip=192.168.xx.xx latency=0 link=yes multicast=yes wireless=IEEE 802.11abgn
       resources: irq:31 memory:f7d00000-f7d01fff

iwconfig gives:

wlp2s0    IEEE

 802.11abgn  ESSID:"Our Internet"  
          Mode:Managed  Frequency:5.785 GHz  Access Point: 70:8B:CD:CD:6A:04   
          Bit Rate=216 Mb/s   Tx-Power=15 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:on
          Link Quality=47/70  Signal level=-63 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:13  Invalid misc:101   Missed beacon:0

iwlist scan gives:

wlp2s0    Scan completed :
          Cell 01 - Address: 70:8B:CD:CD:6A:04
                    Channel:157
                    Frequency:5.785 GHz
                    Quality=45/70  Signal level=-65 dBm  
                    Encryption key:on
                    ESSID:"Our Internet"
                    Bit Rates:6 Mb/s; 9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s
                              36 Mb/s; 48 Mb/s; 54 Mb/s
                    Mode:Master
                    Extra:tsf=00000027b06e54a4
                    Extra: Last beacon: 48164ms ago
                    IE: Unknown: 000C4F757220496E7465726E6574
                    IE: Unknown: 01088C129824B048606C
                    IE: IEEE 802.11i/WPA2 Version 1
                        Group Cipher : CCMP
                        Pairwise Ciphers (1) : CCMP
                        Authentication Suites (1) : PSK
                    IE: Unknown: 2D1AEF0917FFFFFF0000000000000000000000000000000000000000
                    IE: Unknown: 3D169D0D1500000000000000000000000000000000000000
                    IE: Unknown: 7F080000000000000040
                    IE: Unknown: BF0CB259820FEAFF0000EAFF0000
                    IE: Unknown: C005019B000000
                    IE: Unknown: C30402020202
                    IE: Unknown: DD09001018020E001C0000
                    IE: Unknown: DD180050F2020101840003A4000027A4000042435E0062322F00
5
  • Please post the output of iwconfig to see the link quality, signal strength, errors. Any noisy neighbors on your channel? Check with sudo iwilist scan. – ubfan1 Feb 15 '18 at 16:28
  • I'm not quite sure how to interpret the output of iwlist scan but the wifi generally worked up until the password change so I would assume it's not an external factor. I feel like it may be something to do with the password not getting saved correctly? But I'm not sure how to check this – Indigo Feb 15 '18 at 20:48
  • A connection shows the password is OK. Use sudo on the iwlist scan to get all the other accesspoints within range, and check the frequency and quality. Any other access points on your channel is not good. If they are stronger than yours, thats really bad. Any local changes like repositioniing your pc or hub to improve signal strength might help. – ubfan1 Feb 16 '18 at 1:37
  • Oh wow, so it looks like we have four access points all with the same ESSID, one on its own channel, one on a channel shared with two other access points of about the same strength, and two on a channel thats shared with about a dozen other access points of varying strengths. I can't physically move since I'm in a office but is there a way I can tell nmcli to only connect to the access point on its own channel and ignore the others? – Indigo Feb 16 '18 at 14:40
  • Try setting the BSSID to the access point address you want (the address shown just after "Cell" on the scan list, first line. Try blocking other accesspoints with metal objects, like aluminum foil on a notebook placed near your PC. Can you change your ESSID to something non-conflicting? – ubfan1 Feb 16 '18 at 17:37
0

I had a similar problem. It solved when I restarted the NetworkManager.

In my system:

systemctl restart NetworkManager

Maybe it's some kind of password caching. I hope it helps

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.