I want to open a java web application (Mirth Connect) on my Ubuntu machine. So following the tips on this page I installed icedtea:

sudo apt-get install icedtea-netx

and then executed the jnlp file I downloaded:

javaws webstart.jnlp

I then get this screen:

enter image description here

And whichever button I press (Yes, No, close) it constantly reloads this screen and refuses to proceed to the rest of the application.

On my Mac this application works perfectly well.

Does anybody know why this happens on Ubuntu, and how I can get it to work?

  • Is there any terminal output to the javaws command? What Java and IcedTea version is this? What's the output of javaws -version and update-alternatives --list javaws? Feb 21, 2018 at 14:03
  • 2
    I also faced the same issue. I have openjdk installed in my laptop. Removed that and installed oracle jdk and things are working fine. Feb 22, 2018 at 11:46
  • You seem to have redacted some important clues from your image and possibly ignored the "For more information see" section of the output. Neither course of action would I recommend if you expect to receive a quality answer to your question. My gut reaction without being able to see the domain being utilized is just don't! xkill the window.
    – Elder Geek
    Feb 25, 2018 at 16:41
  • @BarathVutukuri - Yes.. That finally solved it! If you add your suggestion as an answer I can accept it.
    – kramer65
    Mar 13, 2018 at 9:39

1 Answer 1


If you have openjdk installed, remove it and install the oraclejdk. It worked for me. You can maintain multiple versions of jdk and switch between each and make them active.

  • No need to uninstall openjdk. Good howto is here: www.digitalocean.com/community/tutorials/how-to-install-java-with-apt-on-ubuntu-20-04
    – u2n
    May 18, 2022 at 21:46

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .