1

I am trying to assign ownership of a certain file (FILE) to a user (A). I log in as root and run chown A FILE but nothing happens. If I add the group option (chown A:A FILE), the group is changed but the user is not.

If I try with another user (B: chown B:A FILE) it works. Could anyone tell me why a specific user cannot own a file? I have tried in different locations but the result is always the same.

  • 2
    Who is A? Does A have some special characters in his name? – muclux Feb 15 '18 at 7:08
  • 1
    try it with the id, instead of the name. to find out the id, use id <username> – Robert Riedl Feb 15 '18 at 11:28
  • A is "bitnam"i and has no special characters. Besides I have tried with the id code obtained after running "id bitnami" and it does not work either. If I follow the same procedure with user B (which is testuser) it does work. – Jordi Rocafull Feb 16 '18 at 4:24
  • I do not know if it might have something to do with the fact that I have run a few times a Magento linux installer which creates users and its main user is "bitnami" (the user I am encountering problems with) – Jordi Rocafull Feb 16 '18 at 4:29
  • I have deleted A user and created again but the problem persist – Jordi Rocafull Feb 16 '18 at 4:33

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.