1

I recently partitioned my hard drive to install ubuntu 17.10 and to use CUDA. I have run into a non-resolving problem. I have

  • Followed the exact steps as stated in How can I install CUDA 9 on Ubuntu 17.10. The message I keep on receiving is (after rebooting in insecure mode, and then running the CUDA run file):

    ***WARNING: Incomplete installation! This installation did not install the CUDA Driver. 
     A driver of version at least 384.00 is required for CUDA 9.0 functionality to 
    work.
    

    This makes no sense, as I have successfully installed 384.111 previously. My output when I run

    $ nvidia-smi 
    

    is

     NVIDIA-SMI 384.111                Driver Version: 384.111                   |
    |-------------------------------+----------------------+----------------------+
    | GPU  Name        Persistence-M| Bus-Id        Disp.A | Volatile Uncorr. ECC |
    | Fan  Temp  Perf  Pwr:Usage/Cap|         Memory-Usage | GPU-Util          Compute M. |
    |===============================+======================+======================|
    |   0  GeForce GT 740M     Off  | 00000000:01:00.0 N/A |                  N/A |
    | N/A   54C    P0    N/A /  N/A |    261MiB /  2004MiB |     N/A      Default |
    +-------------------------------+----------------------+----------------------+
    
    +-----------------------------------------------------------------------------+
    | Processes:                                                       GPU Memory |
    |  GPU       PID   Type   Process name                             Usage      |
    |=============================================================================|
    |    0                    Not Supported                                       |
    +-----------------------------------------------------------------------------+
    
  • So naturally my next step was to try another method of updating my driver. Attempting to run the run file for the latest driver(I made it executable and ran it with sudo) yielded the error:

    ERROR: An NVIDIA kernel module 'nvidia-drm' appears to already be loaded in  
     your kernel.  This may be because it is in use (for example, by an X  
     server, a CUDA program, or the NVIDIA Persistence Daemon), but this   
     may also happen if your kernel was configured without support for     
     module unloading.  Please be sure to exit any programs that may be    
     using the GPU(s) before attempting to upgrade your driver.  If no     
     GPU-based programs are running, you know that your kernel supports    
     module unloading, and you still receive this message, then an error   
     may have occured that has corrupted an NVIDIA kernel module's usage   
     count, for which the simplest remedy is to reboot your computer.    
    

    So I rebooted and still received the same error. So its either an X server or the NVIDIA Persistence Daemon.

  • From there I followed the steps from How to install NVIDIA.run? except I stopped the service gdm3 instead of lightdm, this was to disable the X server. After this I attempted to run my driver file again, but got the same error.
  • My next attempt was to blacklist the

    nvidia_drm
    nvidia_modeset
    nvidia_uvm
    nvidia
    drm_kms_helper
    

    modules but after rebooting and then running the driver executable, the same error as in bullet 2 occurred.

  • I have also tried using the preinstalled software Additional Drivers in software and drivers. This seemed to work fine until the same error as in bullet 1 popped up again, after trying to run the CUDA run file.

  • Where do I go from here? Is there anyway to disable the NVIDIA Persistence Daemon?

1

You can install the Nvidia drivers from the Ubuntu preinstalled program called Additional Drivers. Search into dash or whatever your DE search has and open it. Then spot the list of available drivers for your graphics card and select the driver you want. After that click apply, type your password and maybe you need a reboot or a logout-login before you use the drivers.

  • I have tried this route but wounded up with the same error as I got in bullet 1 after trying to run the cuda run file again. – Conrad Strasheim Feb 14 '18 at 21:30
0

Ubuntu 17.10 Installs Wayland with the option for XServer using Gnome (GDM3) or Ubuntu (still GDM3 Now!), all at the login screen. Awesome!

If one uses autologin it often (always in my case Ubuntu STUPIDLY!! reverts to Wayland which at this time (March 2018) still does not have Nvidia support and it SCREWS up your boot with

Nvidia Persistent Daemon start/stop .... FOREVER - Endless Loop

if this happens Purge nvidia from Ubuntu "Rescue" then, Disable Wayland in your newly functional Ubuntu

sudo gedit /etc/gdm3/custom.conf

and uncomment "#WaylandEnable=false", to read "WaylandEnable=false"

and re-install your Nvidia Drivers

All will be fine now

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.