0

I have installed Ubuntu 16.04 on my system via dual boot. I am able to connect to the Internet via Ethernet, but the wifi does not seem to work on my OS. I have already tried the solutions mentioned in 1. WIfi dropping problems in Lenovo Y520 legion 2. WI-FI doesn't work (Hard Blocked) But still I have not been able to fix the problem.Can somebody help me out with the issue ?

  • please show what you obtain with lspci | grep Network and sudo iw dev – kcdtv Feb 14 '18 at 20:04
  • @kcdtv Here is the output I get for the first command. imgur.com/a/91eIp I did not get any output for the second command. – user564650 Feb 15 '18 at 4:38
  • According to lspci you have an Intel wifi chip. The fact that it doesn't shows up with ìw devindicates that you lack a firmware (and a driver). One weird thing: In the first link you gave the user has a Realtek chipset. Could you add in your first message the full output of lspci? Can you somehow identify the wifi chipset? Maybe in your manual? – kcdtv Feb 16 '18 at 10:33
  • @kcdtv Here is the full output of lspi imgur.com/a/aeO1p . I could not find any wifi information on the manual, but did locate 'Intel(R) Dual Band Wireless-AC 8265' under network adapters in the device manager while using windows. – user564650 Feb 16 '18 at 19:48
0

Your WiFi chipset is an Intel(R) Dual Band Wireless-AC 8265. Check if iwlwifi is installed.

It seems that installing the generic package for Intel WiFi would not be enough and you will have to manually place the firmware for your WiFi chipset.

Download it: iwlwifi-8265-ucode-22.361476.0.tgz.

Unpack it and copy it in your /lib/firmware directory:

sudo cp ~/Downloads/iwlwifi-*.ucode /lib/firmware

And then load the driver with:

sudo modprobe iwlwifi

This information (and more) is available in linux wireless / iwlwifi

  • I tried the above mentioned 2 commands, but did not get any output for either of them. I rebooted the system after the execution of the commands and the problem still persists. – user564650 Feb 22 '18 at 2:08
  • Also if I use the command rfkill list, I only get the output for bluetooth and nothing for wireless. Plus I again tried the commands lspci | grep Network and sudo iw dev, and again got the same outputs as before. – user564650 Feb 22 '18 at 2:27
  • Try to install linux-headers-amd64. Did you installed your Ubuntu system with the "secure boot" feature enabled? – kcdtv Feb 22 '18 at 15:54
  • I am finding 2 commands on the net regarding this installation, which one should I use? 1. sudo apt-get install linux-headers-$(uname -r) or 2. sudo apt-get install linux-headers-generic . Also I don't clearly remember the secure boot status during the time of installation of ubuntu as I had previously modified it a couple of times. But right now it is disabled. – user564650 Feb 23 '18 at 7:41
0

You can use these commands:

sudo modprobe -r ideapad-laptop
sudo rfkill unblock all
rfkill list all

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.