1

I have a problem with my keyboard keys. If i press a key it will say something else

I am using English(UK) layout

I tried to change the keyboard layout but no luck.

Any help?

Edit

Results for:xmodmap -pke | grep slash

`keycode  20 = minus underscore minus underscore backslash questiondown 
backslash
keycode  28 = t T t T tslash Tslash tslash
keycode  32 = o O o O oslash Oslash oslash
keycode  61 = slash question slash question dead_belowdot 
dead_abovedot dead_belowdot
keycode  94 = backslash bar backslash bar bar brokenbar bar`
  • i do not know how to find out what which layout im using – Ots Wng Feb 14 '18 at 16:26
  • i am using English(UK) layout – Ots Wng Feb 14 '18 at 16:29
  • From a terminal, check the result of $ xmodmap -pke | grep slash – Aaron Feb 14 '18 at 16:33
  • You need to use a keyboard layout which matches your physical keyboard. So in order to help you, we need to know both for which language your physical keyboard is designed and which keyboard layout (a setting) you have applied. A pic of your physical keyboard would help. – Gunnar Hjalmarsson Feb 14 '18 at 16:35
  • Go to the top right corner set of icons and select the screwdriver-wrench icon to open settings. Then on the left panel select "Region and Language" You will see input sources, and below it the layouts installed. By default it should say "English (UK)" only. – user68186 Feb 14 '18 at 16:36
1

Go to the settings and in the language section, add English(Australian) as that will correct your keyboard layout.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.