0

enter image description hereHello I am running Xubuntu 16.04 (kernal is 4.13.0-32-generic) on an Asus laptop, after unplugging headphones the speakers are not working. I have searched a lot of old posts and found no explanation.

Looking at Sound Settings, on the output devices tab, headphones are marked as plugged in, when they are not, and speakers marked as unavailable.

I would be grateful for any help and suggestions with this problem.

Thanks in advance, PC.

  • When you reboot with no headphone pluged, does it work? Sound & microphones are quite strangely supported on linux, and actually I've some trouble on my own laptop with microphone that I was not able to completely solve, so I may not be the bigger help, but I can just advise you to look the option snd-hda-intel mode. [part 1] – tobiasBora Feb 14 '18 at 15:43
  • [part 2] For me adding options snd-hda-intel model=,dell-headset-multi in the new file /etc/modprobe.d/alsa-base.conf and reboot solved some problems. You just need to find the good model (there are plenty of models), and put it on the good card (there is a comma before dell... because the first card is hdmi on my system). In order to make it easier to find, try to post the result of lspci (and a link to a paste of your lshw). – tobiasBora Feb 14 '18 at 15:44
  • Thanks for getting back to me tobias, no rebooting with the headphones out had no effect. My codecs are as follows: Intel Haswell HDMI, Realtek ALC3236. I couldn't find a model for ALC3236. So i added the line snd-hda-intel model=auto to /etc/modprobe.d/alsa-base.conf, this did not help. Maybe you could suggest a model for ALC3236? – paulc Feb 15 '18 at 0:40
  • Really? It's the same as me. I have no problem with sound with options snd-hda-intel model=dell-headset-multi (if your card is "card 1" when you run aplay -l you would need to add a coma just before dell like in my above example). But my microphone is buggy when I try to plug my headphone, I need to chose between a working internal microphone and a working headphone microphone. Does it work for you? – tobiasBora Feb 15 '18 at 14:04
  • Maybe this is related, but it's a fix for mac youtube.com/watch?v=MTbVfRXMJ2I – tobiasBora Feb 15 '18 at 14:06
0

For anyone else having these sorts of audio issues, I fixed my problem as follows:

It turns out a lot of these issues are caused by false data being passed from the BIOS to ALSA, e.g. in my case the BIOS was communicating to ALSA that headphones were plugged in, when they were not. This miscommunication needs to be overridden.

Firstly install ALSA tools gui:

sudo apt install alsa-tools-gui

A number of links will appear in the multimedia tab of your menu. Select the link named HDAJackRetask, when the gui opens select the appropriate codec and override the erroneous BIOS messages with what you require. See attached image.enter image description here

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.