0

I'd like to use raspberry pi 3 + ubuntu for an "audiophile" sound. I have a m2tech Hiface Evo card that is connected to an external DAC. I tried to use mpd + alsa with good results, but I would try to compare it with the Rhythmbox player using Gstreamer. Now, the audiophile sound provides, among other things, the disabling of the volume. Hiface hasn't a hardware or software volume control. In the mpd's config, however, I disabled the mixer with the value "none" and so I am sure I haven't the volume control (in various mpd's front-ends the volume bar is either disabled or has no effect on the sound). I would like to achieve the same result with Rhythmbox and Gstreamer, but I can't find the right command on the web documentation. The Rhythmbox's volume control has effects on reproduction. I precise that I have disabled Pulse and that I use alsa with Gstreamer. How can I disable the volume on Gstreamer (or Rhythmbox) settings? Thanks in advance!

0

Try to remove, update and install the drivers for it.

sudo apt-get update

If you also want to delete your local/config files for rhythmbox then this will work:

sudo apt-get purge rhythmbox
sudo apt-get autoremove

OR

sudo apt-get remove rhythmbox
sudo apt-get remove --auto-remove rhythmbox
sudo apt-get install xxxx

While some may find it useful to have music players listed in the sound indicator menu with individual controls, installers of multiple software may want to blacklist some media players from appearing there. It can be done with this simple command, or edited in dconf Editor.

First, open the Terminal, then execute the following code:

gsettings set com.canonical.indicator.sound blacklisted-media-players "['rhythmbox']"

OR

Simply follow the instructions on this web page:

https://www.howtogeek.com/113897/how-to-remove-media-players-from-ubuntus-sound-menu-add-your-own/

6
  • Thanks for your reply. I'll try this evening... But there's one thing I'd like to understand... Rhythmbox uses Gstreamer. Is there a way to disable volume control in Gstreamer as in mpd in its mpd.conf (mixer=none or disable)? – Marco Casella Feb 14 '18 at 15:19
  • No worries, welcome :) I think you could try this but revert back changes if you think something went wrong. There's 'replay_gain_handler' parameters are: <software, mixer or none> According to 'mpd.conf' man page, It specifies how replay gain is applied. The default is "software", which uses an internal software volume control. "mixer" uses the configured (hardware) mixer control. "none" disables replay gain on this audio output. Remember to reboot or logout/login for changes to take effect after running these commands. Let me know if you can make it work! – Shaze Feb 14 '18 at 17:00
  • Manual for mpd.conf: linux.die.net/man/5/mpd.conf – Shaze Feb 14 '18 at 17:00
  • The parameters that I use in mpd.conf for alsa are these: audio_output audio_output { type "alsa" name "My ALSA Device" device "hw:0,0" # optional mixer_type "none" mixer_device "disabled" mixer_control "PCM"} – Marco Casella Feb 14 '18 at 17:53
  • Is there something similar for Gstreamer? – Marco Casella Feb 14 '18 at 17:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.