libimobiledevice doesn't work for me. I've got Ubuntu 11.10 and I'm trying to put music on to my iPod Touch 4Gen running iOS 5.0.1.

I have tried every program available in the Ubuntu software center for sycing iPods and I get basically the same response from each one: "[cannot apply changes etc, ect, etc]" I've tried rigorously with Banshee and Rythmbox with no success.

I've even tried running iTunes on Windows XP in VirtualBox with no success. I've tried running iTunes through Wine and it results in an error message saying something along the lines of "[Please install Apple Application Support and then reinstall iTunes]". I am considering Jailbreaking my iPod but I cannot find Absinthe that works with my iPod and with Ubuntu. In addition I'm not sure how ** works with Ubuntu. I'm really in a pickle here.

It would be ever so helpful if I could indeed have some help with this issue.


I have tested gtkipod with Ipod Touch 4 Gen but 8GB. I also tried Banshee and Rhythmbox, both failed. Even with the latest Shuffle or Nano.

First install the gtkpod iPod Manager (Install link) in the Software Center.

Screenshot of the software center

As you can see when starting the program it has on its list the 4 Gen of Touch:

Screenshot of gtkpod

Also checked with latest Shuffle and works. The only one that works actually.

If a user uses Banshee or even Rhythmbox they will hear a woman in the Ipod saying that you need to sync it with itunes. The only one I have known that correctly syncs is gtkpod.

UPDATE - Funny, today my Ubuntu got 2 updates in the Update manager about Iphones and Ipod.


To elaborate on Mark's answer, apps like RhythmBox and Banshee and others rely on gtkpod to be able to sync properly - to update the database file on the ipod. This works for older iOS versions earlier than 5, but with version 5 Apple changed the checksum algorithm used on the database file to lock out other applications and no one has yet (as of 6-Feb-2012 AFAIK) figured out the algorithm. Reference from October.

There is already at least one bug in Launchpad about it: Bug # 601251 - Rhythmbox/gtkpod can't write to iPad music database.

I have found several mentions of methods to get it to work, but they all require jailbreaking your iPod and manually reverting the internal database version marker from 5 to 4 (or earlier). I've not be willing to do this yet, but here's one example (I have not tried this).
Getting iPod syncing working with 4G touch - iOS5

More googling for 'ipod 4g sync ubuntu' will find more links to other descriptions of this technique.

For now, we can't sync unbroken iOS5 devices in Ubuntu. I've built a Windows VM in virtualbox and put iTunes on it and have done syncing through that, though it's overkill (uses way more memory than I'd like so I don't do it often).


The current version of gtkpod does not support the 4th gen iPod Touch see the SourceForge release notes here


Your Windows on Virtualbox solution may be the only viable way, but you have to install guest additions to enable USB 2.0 controllers, and so make it able to your iPod to connect to the Windows inside Virtual Box. Good luck! ;)

Not the answer you're looking for? Browse other questions tagged or ask your own question.