0

Hibernation worked flawlessly on Windows 10 just before I've switched to Ubuntu (16.04), so I know for sure that the laptop (Lenovo y50) supports it.

Here's some info about the system:

$ sudo systemctl hibernate
Failed to hibernate system via logind: Sleep verb not supported
$ free -m
              total        used        free      shared  buff/cache   available
Mem:          15952        2953       11727         409        1271       12258
Swap:         16295           0       16295
$ cat /sys/power/state
freeze mem
$ ls /lib/modules/$(uname -r)/kernel/drivers/acpi
acpi_configfs.ko  acpi_ipmi.ko  apei  ec_sys.ko  sbshc.ko  video.ko
acpi_extlog.ko    acpi_pad.ko   dptf  nfit       sbs.ko

Tried the instructions of the docs, editing the file with the right config:

/etc/polkit-1/localauthority/50-local.d/com.ubuntu.enable-hibernate.pkla

[Re-enable hibernate by default in upower]
Identity=unix-user:*
Action=org.freedesktop.upower.hibernate
ResultActive=yes

[Re-enable hibernate by default in logind]
Identity=unix-user:*
Action=org.freedesktop.login1.hibernate;org.freedesktop.login1.handle-hibernate-key;org.freedesktop.login1;org.freedesktop.login1.hibernate-multiple-sessions;org.freedesktop.login1.hibernate-ignore-inhibit
ResultActive=yes

Also tried other locations, which I've found in other places on the internet: /var/lib/polkit-1/localauthority/10-vendor.d/com.ubuntu.desktop.pkla

1

According to this answer, disabling secure boot in the Bios setting seems to solve the problem.

  • Worked! Had to disable Secure Boot, as suggested in the link. Thanks! – Poni Feb 14 '18 at 19:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.