1

I'm looking into Landscape for managing our ubuntu clients within our business in a more efficient way however I'm running into problems at the first hurdle.

I've installed Ubuntu server 16.04.03 LTS in an ESXi VM and tied the 17.03 quickstart install I'm following the basic instructions: https://landscape.canonical.com/set-up-on-prem

But get the following results:

DERLAND01:~$ sudo apt install landscape-server-quickstart
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies.
 landscape-server-quickstart : Depends: landscape-server (>= 17.03.3-0ubuntu1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

The server is a plain vanilla install with only an IP address and domain suffix changes. I've also tried performing sudo apt-get upgrade before I run the apt install but to no avail.

After a few tips from internet searches, I used sudo aptitude install landscape-server-quickstart rather than apt to see if I can get a more detailed output and then get complaints about juju:

The following packages have unmet dependencies:
 juju : Depends: juju-2.0 (>= 1:2.1.2-0ubuntu1~16.04.1~juju1) but it is not going to be installed.
The following actions will resolve these dependencies:

     Keep the following packages at their current version:
1)     juju [Not Installed]
2)     landscape-server [Not Installed]
3)     landscape-server-quickstart [Not Installed]

     Leave the following dependencies unresolved:
4)     landscape-hashids recommends landscape-server


Accept this solution? [Y/n/q/?]

I've also tried installing the latest stable juju from the ppa, but to my understanding juju should already be taken care of by the landscape install.

If I revoke to my VM to post OS install snapshot and run through the process with Landscape 16.06 ppa - everything works fine. Am I missing something obvious or is something broken?

Any help would be appreciated as I've been going round in circles for hours!

Thanks! Rich

  • 1
    OK - problem now resolved. i386 ISO was used to build the server - now using AMD64 and all is well. – Richard Ferris Feb 14 '18 at 11:07
  • please post your solution as an answer and accept it, so searcher know that there is a solution – ravery Feb 18 '18 at 0:47
1

You must use an amd64 system.

A bit obtusely, but it's documented here:

You can install Landscape On Premises on any server with a dual-core processor running at 2.0GHz or higher, at least 4GB of RAM, and 5GB of disk space. The operating system must be Ubuntu Server 12.04 LTS x86_64 or higher. You must also have PostgreSQL installed and network ports 80/tcp (http) and 443/tcp (https) open. You can optionally open port 22/tcp (ssh) as well for general server maintenance.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.