This question already has an answer here:

I always keep my system up to date, but reboot it not very often. After an reboot the repeating input (if you hold down a key) of the keyboard stoped working. After some test with live image and so on I can give the following facts.

  1. its not the keyboard (tried another one)
  2. Its all keys (even backspace - what is really annoing)
  3. It depends not to my user
  4. it depends not on the Desktop
  5. IT DEPENDS ON MY INSTALLATION (live image works fine)

When I start a terminal session via Strg+Alt+F1 then it constantly fills the input with this: "^@" so after a while it looks like


In the GUI it does not show this BUT I'm sure thats the problem.

Could not find anything online - so I hope anybody of you can help me out!

My system: LinuxMint 18.3 (based on Ubuntu 16.04) Kernel: 4.13.0-32-generic

marked as duplicate by karel, WinEunuuchs2Unix, Eric Carvalho, waltinator, Yaron Feb 14 '18 at 15:35

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 1
    On the duplicate question's answer you can find various options to address the keyboard repeat problem on kernel 4.13.0-xx – WinEunuuchs2Unix Feb 14 '18 at 11:30

I found a solution for now.

Switching back to Kernel 4.10.42 fixed that issue. So it's somehow the Kernel 4.13 (I tried several Versions of it and all fail) that couses the issue.

As WinEunuuchs2Unix commented there are some possibility to fix this. See comments above. Thanx!

Not the answer you're looking for? Browse other questions tagged or ask your own question.