Is it possible to specify a desktop resolution for the built-in ubuntu 11.10 vnc server? It defaults to 640x480 when I have no monitor connected (headless), and I can't find a way to change it. Does it have any command line parameters?

A similar issue has been posted:

Set screen resolution when booting with no screen

Note: The box is set to auto-login, so if I can change the auto-login resolution (with no monitor), that could possibly help.

1 Answer 1


Figured it out myself, finally.

Apparently the problem was that since there is no monitor, no valid "screens" are started up when the box boots, and therefore no resolutions are available in the Unity settings dialog.

However, when no screens are found, it seems the system defaults to a "virtual desktop", with a 640x480 resolution. The system does support virtual desktops that have different resolutions than the connected monitors (in this case none), so the trick was to change the default virtual desktop resolution. That can be done in the /etc/X11/xorg.conf.

My file currently looks like this.

Section "Device"
       Identifier      "Default Device"
       Option  "NoLogo"        "True"

Section "Monitor"
   Identifier    "Configured Monitor"

Section "Screen"
   Identifier    "Default Screen"
   Monitor        "Configured Monitor"
   Device        "Default Device"
   SubSection "Display"
       Depth    24
       Virtual 1280 800

This seems to suffice, and you can change the "Virtual 1280 800" section to whatever you want. And the reboot the box. I am using the built-in vino VNC server.

  • Is it possible to configure the built-in VNC server to "serve" a multi-monitor desktop? In my case 4 x fullHD? And do those monitors have to be configured as one big rectangle or can I go with some portrait mode, some landscape, ie, 4 independent monitors as per Windows, Mac, or indeed Ubuntu monitor config tools? Jan 21, 2014 at 10:33
  • I'm sorry, that I do not know. You'll have to read up on X server configuration, or post another question.
    – Yngvefaen
    Feb 19, 2014 at 5:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.