1

I recently installed lubuntu 17.10.1 desktop i386 on an old laptop and I'm having troubles with some log in pages (e.g ebay and amazon) not responding.

For example if I try to log in on ebay, after I fill my credentials and click log in, the loading icon (on Firefox) starts spinning and nothing happens. The status bar simply reports:

Sending request to signin.ebay.it...

and nothing happens. The response page simply won't load. On chromium, instead, after a while the following message appears:

An error occurred while processing your request.
Reference #27.dfc1402...

Addtionally:

  • using an ethernet connection everything works fine. THIS HAPPENS ONLY ON WIFI;
  • when I had Windows 7 installed everything worked fine even on wifi;
  • as far as I can tell this stuck-behavior happens for many but not all log in pages and for a few of them, after re-launching Firefox, I appear to be logged in (imdb.com, goodreads.com); That is, the log in process gets completed but the page isn't loaded properly;
  • I can, for example, log in to stack overflow and google without issues;
  • I also get stuck on some normal pages quite randomly;
  • on amazon I can't even load the log in form;
  • this happens with both Firefox Quantum and Chromium (latest versions);
  • EVERY OTHER device at home (2x Android devices and Windows Desktop PC) works fine over wifi.

sudo lshw -c network returns

*-network:1
       description: Wireless interface
       product: AR2413/AR2414 Wireless Network Adapter [AR5005G(S) 802.11bg]
       vendor: Qualcomm Atheros
       physical id: 4
       bus info: pci@0000:09:04.0
       logical name: wlp9s4
       version: 01
       serial: 00:16:e3:e0:91:54
       width: 32 bits
       clock: 33MHz
       capabilities: pm bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=ath5k driverversion=4.13.0-32-generic firmware=N/A ip=192.168.0.91 latency=168 link=yes maxlatency=28 mingnt=10 multicast=yes wireless=IEEE 802.11
       resources: irq:22 memory:c0110000-c011ffff

I tried a few possible solutions I found over the web, but they didn't work and with me being quite new to linux, I don't know what else to do. I tried:

  • disabling DNSSEC on /etc/systemd/resolved.conf (DNSSEC=no)
  • network.dns.disable.IPv6 set to false on Firefox
  • turning off proxies on Firefox
  • setting the wireless interface mtu to 1200 (1500 would be the default)
  • Are you using your wifi connection with the ethernet cable plugged in? – Girol Feb 13 '18 at 16:39
  • No. And throughout my testing I found more problems like "Cannoct contact reCAPTCHA", reddit constantly crashing (not even loading) on Firefox or sites randomly hanging (always only on wifi). Next step I'll probably try to install different drivers or emulate the windows proprietary ones (if possible). I just can't pinpoint the problem. – type-a1pha Feb 13 '18 at 17:11
  • Did you tried this fix? ubuntuforums.org/showthread.php?t=1345078 – Girol Feb 13 '18 at 17:22
  • I tried but the repository isn't online anymore so I gave up. I also tried with ndiswrapper and the windows driver but I couldn't get it to work. On the other end after turning off the encryption on my wifi connection, everything works fine with the ath5k drivers. Thus the problem involves the encryption protocols and some conflict/configuration of sorts. I tried with every protocol available in my router (WEP and WPA variants) and sadly all of them seems to have the same issues. – type-a1pha Feb 14 '18 at 1:07
1

I found the solution which is detailed in this very old ubuntu bug report.

That is, the ath5k module needs to be loaded with the nohwcrypt option. The following lines achieve the desired result:

sudo modprobe ath5k nohwcrypt
sudo sh -c "echo 'options ath5k nohwcrypt' >/etc/modprobe.d/custom-wireless.conf"

A few additional explanations can be found in this wiki.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.