3

I installed GNOME Control Center following this instructions to access Google Drive in Ubuntu MATE 16.04 LTS (MATE desktop environment 1.12.1)

The problem is GNOME Control Center is only showing language support, printers, firewall setup and backups... not online accounts or other settings.

This is what I get:

~$ gnome-control-center gnome-online-accounts 

** (gnome-control-center:5744): WARNING **: Ignoring launcher landscape-client-settings (missing desktop file)

** (gnome-control-center:5744): WARNING **: Invalid categories System;Settings; for panel software-properties-gtk.desktop

** (gnome-control-center:5744): WARNING **: Ignoring launcher ubuntuone-installer (missing desktop file)

** (gnome-control-center:5744): WARNING **: Could not find settings panel "gnome-online-accounts"

Any ideas?

Thanks!

  • Yes, I did. I followed the instructions. sudo apt install gnome-control-center gnome-online-accounts (I also try "sudo apt install gnome-online-accounts" alone) – ifrit Feb 13 '18 at 10:18
  • Probably it's not feasible with MATE, the linked article doesn't say it will wok with MATE. It seems it's about making it work in vanilla Ubuntu 16.04 (Unity). To make Google Drive integration work, you'll most likely need Nautilus. But MATE uses Caja as the file manager. – pomsky Feb 14 '18 at 16:12
2

You can read my fresh analysis of Google Drive integration into Ubuntu MATE 16.04 LTS on the ubuntu-mate.community.

Previously I was thinking that Online Accounts are located in gnome-control-center, but really it is located in two packages account-plugin-google and unity-control-center-signon. You can install them with

sudo apt-get install account-plugin-google unity-control-center-signon

and then run

credentials-preferences

but this does not change anything on 16.04 LTS. This does not enable Google Drive in Caja.

After some trial and error I'm happy with the following solution.

  1. I installed Grive2 from WebUpd8 PPA:

    sudo add-apt-repository ppa:nilarimogard/webupd8
    sudo apt-get update
    sudo apt-get install grive
    
  2. Then I installed grive-tools package manually from The Fan Club Grive Tools PPA (they does not have packages for 15.10 and newer versions):

    wget https://launchpad.net/~thefanclub/+archive/ubuntu/grive-tools/+files/grive-tools_1.15_all.deb
    sudo gdebi grive-tools_1.15_all.deb
    
  3. Then I ran grive-setup and set-up my Google account

    /opt/thefanclub/grive-tools/grive-setup
    
  4. After this I enabled indicators in mate-tweak (System -> Preferences -> Look and Feel -> MATE Tweak)

    Interface tab -> Panel Features -> Enable Indicators

  5. Logged out

  6. After log-in grive-indicator is shown and started to sync my Google Drive automatically

    grive-indicator

  7. To hide its notification I opened Preferences and unchecked Show On Screen Notifications

    grive-indicator properties

  8. To be more productive I added ~/Google Drive folder to Bookmarks with Ctrl+D in Caja.

I'm comfortable with this solution.

  • 1
    Thanks for your answer! My solution was FUSE astrada.github.io/google-drive-ocamlfuse (I can write the process later) – ifrit Mar 9 '18 at 8:27
  • Unfortunately it is no longer possible to install grive-tools because of a failed dependency to gksu .. – obaqueiro May 18 at 15:27
  • gksu is still installable with method from my other answer. Just tested on 18.04 LTS. – N0rbert May 18 at 15:41
1

I found other solution to get GNOME Online Accounts working on MATE.

On Ubuntu MATE 16.04 LTS we need the following

  1. install one package:

    sudo apt-get install gnome-online-accounts
    
  2. And then set-up Google account in gnome-control-center:

    env XDG_CURRENT_DESKTOP=GNOME gnome-control-center online-accounts
    
  3. Afterwards you will get your Google Drive in the Devices section of Caja named username@gmail.com. If you open this folder in Caja, then its location would be google-drive://username@gmail.com. This folder is synced automatically. But Google Docs will be opened in the browser.

Hope this helps.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.