0

I wanted to mount permanently a ssh driver. in my /etc/fstab I added the following line.

sshfs#ubuntu@xx.xx.xx.xx:/ /home/me/EC2 fuse
user,_netdev,IdentityFile=/home/me/.ssh/magento.pem,uid=root,umask=0770 0 0

But after reboot I cannot open the driver and get this error :

You do not have the permissions necessary to view the contents of “EC2”.

  • A umask is a bitwise complement of the permissions that you want - so my guess is you'd need umask=0007 (although 0027 or 0022 would likely be more standard). See for example Setting umask for sshfs mount (note in particular the comment "If setting non-executable umask bit it won't be possible to list directories") – steeldriver Feb 13 '18 at 13:17

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.