2

I have Sony VAIO VPCEB26FG. I installed ubuntu 11.04. When i switch on my wireless button only bluetooth gets activated and it shows wireless is disabled by hardware switch. I tried using command $sudo rfkill list. The output of which is

kiran@sytem:~$ rfkill list  
0: sony-wifi: Wireless LAN  
    Soft blocked: no  
    Hard blocked: no  
1: sony-bluetooth: Bluetooth  
    Soft blocked: no  
    Hard blocked: no  
2: phy0: Wireless LAN  
    Soft blocked: no  
    Hard blocked: no  
3: hci0: Bluetooth  
    Soft blocked: no  
    Hard blocked: no  

How to solve this problem??

4
  • Try to look in the BIOS settings the internal devices that are controlled by the switch. Report back if you see anything.
    – Severo Raz
    Feb 1, 2012 at 18:11
  • nothing in BIOS settings... Feb 2, 2012 at 2:59
  • Instead of commenting back here, I posted an answer. Please read it and post any follow-up comments on it.
    – Severo Raz
    Feb 2, 2012 at 7:17
  • I have same issue I had windows 7 but didn't work so I had to use portable ubuntu boot It worked fine for months...but now i have same issue and I have no idea anything about commands Someone give me a instructions for like a noob ( me )
    – user286783
    May 30, 2014 at 9:52

4 Answers 4

5

This solved my problem on my Vaio vpceg:

sudo gedit /etc/rc.local

Place this above the exit 0 line:

rfkill unblock wifi
rfkill unblock all
sudo modprobe -r acer_wmi
2

I will ask you to try this, which once consisted of a temporary fix to a problem I had:

  1. Turn the switch off
  2. Run rfkill block wifi
  3. Turn the switch on now
  4. Run rfkill unblock wifi

When I did this, my wifi started working. However, rebooting my computer would kill wifi again. My workaround consisted in blacklisting a module called dell_laptop, which was problematic and was blocking my wifi.

So, please run this command and comment what is output, lsmod | grep sony. If the module sony_laptop is loaded, you should proceed to blacklist it, and reboot your computer.

To blacklist a module, run the following command:

sudo echo "blacklist sony_laptop" >> /etc/modprobe.d/blacklist.conf

Which is just a way of appending the echoed line to the file referenced. You might as well do it with your text editor of choice.

If you wonder where am I getting all this voodoo from, check this bug report at Gnome Bugzilla.

8
  • I dont know what solved my problem, before i use the commands you mentioned, my wifi was working and i can see enable wireless option. However wireless networks option is still disabled. Also there is a module sony_laptop in my laptop. Can you tell me how to blacklist it or refer any link? Feb 2, 2012 at 17:09
  • I think it is mentioned in the Gnome Bugzilla link, but I added some instructions there for you.
    – Severo Raz
    Feb 2, 2012 at 17:28
  • Thanks alot Mr. Wolter Hellmund. I hope this will solve my problem permanently. Feb 2, 2012 at 17:57
  • This is how it looks now yfrog.com/nh7xyp Now how can i search for available wireless networks with wireless networks option disabled. Feb 2, 2012 at 18:03
  • There is no "search" function for wireless networks, if you are sure you are within a wireless network, I recommend you to either use the "Connect to a hidden wireless network" or attempt a connection from another computer. There may be a better method, but I am not very experienced with wifi debugging. Have you rebooted the computer to see if the blacklisting worked as a permanent solution?
    – Severo Raz
    Feb 2, 2012 at 20:45
0

I haven't used a Sony Vaio, but other laptops I've used have a function key to disable/enable wireless. It's usually accessed with a "Fn" key in conjunction with some function that is the same color as the Fn key (often blue).

Also, the BIOS often has a setting you can change at boot time. There could be one that makes it default to disabled until enabled.

1
  • i checked BIOS settings but i didn't find anything related to wireless there. Feb 2, 2012 at 2:55
0
sudo echo "blacklist sony_laptop" >> /etc/modprobe.d/blacklist.conf 

seems to work for me. Also, the switch seemed to be tricky and the wi-fi would go out and the switch needs to be flipped occasionally.

Not the answer you're looking for? Browse other questions tagged or ask your own question.