9

Machine:

Ubuntu 17.10 Kernel 4.14 (for battery on my XPS 9560)

Steps to Recreate:

  • connect to the network (RED_STB)
  • enter a user and password
  • when I hit enter it redirects me to another page (wifiinstant.netsecure.pe) which says that it can't be reached, leaving me unconnected.

What have I tried:

  • Manually adding DNS to IPv4 NM settings
  • Adding connectivity to NetworkManager.conf
  • Reconfiguring resolvconf (sudo dpkg-reconfigure resolvconf)

A couple of key points:

  • it works on windows
  • I can connect to other networks no problem

Hardware:

$ lspci | grep Net
02:00.0 Network controller: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter (rev 32)

NetworkManager Config:

[main]
plugins=ifupdown,keyfile

[ifupdown]
managed=false

[device]
wifi.scan-rand-mac-address=no

[connectvitiy]
url=http://nmcheck.gnome.org/check_network_status.txt

Any ideas?

7
  • 1
    I've had similar problems with firefox on ubuntu. You could try going to the page neverssl.com - that's designed to make the network login page appear. – Organic Marble Feb 13 '18 at 0:29
  • This happens with both Firefox and Chrome. I suspect that part of the connection process is redirecting to some site that then gives my MAC a connection, but I can't get redirected to that service/site because it immediately fails on Linux. – Brandon Bertelsen Feb 13 '18 at 0:36
  • Your issue sounds like it may be contained to the web portal. If it works on Windows, you may be denied based on your user agent alone, this is not totally uncommon on public wifi hotspots. Try spoofing your user agent, at least to verify whether the issue is still there or not. Also try spoofing your MAC in case it was blacklisted. – pzkpfw Feb 14 '18 at 8:45
  • Seems to be bug: 1766969 - which is still open. – mike stewart May 11 '18 at 21:55
  • @mikestewart is this a bug though, when they're the ones not following RFC? – Emobe Sep 23 '19 at 13:30
10

Sitting at Starbucks now, it looks like I've found a workaround for this. In my case the error shows the hostname in quotes:

Error resolving “secure.datavalet.io”: Name or service not known

Work Around

  1. In a Terminal, find out the IP address of secure.datavalet.io.

      ip route
    

    (Example output: default via 172.31.98.1)

  2. run sudo nano /etc/hosts to add the IP address and hostname (from error) as a new line in your systems hosts file.

    172.31.98.1 secure.datavalet.io
    
  3. Usually optional, but in some cases where you've previously connected, you may need to also run sudo nano /etc/resolv.conf and insert a line for the first nameserver with the IP address:

    nameserver 172.31.98.1
    
  4. Try to connect to WI-FI again (e.g., through Firefox, which has the functionality of requesting the Network login page).

Explanation

It seems the problem is the hotspot server name (aka WiFi router) cannot be found during normal DNS lookup. This is due to a common out-of-spec router configuration, and the fact systemd operates according to RFC specification.

There is a bug report: 1766969 that seems to identify this problem with WiFi hotspots common to hotel WiFi, coffee shops, and other public WiFi configurations that work on Windows or Apple but not systemd. Hopefully the solution will allow it to fallback to older functionality to fix this common use case. On the bug report at the top, you have the option share that this bug affects you too, and/or be notified when resolved.

10
  • Well done! and welcome to Peru :P – Brandon Bertelsen Mar 31 '18 at 22:50
  • thanks this did the trick! Hopefully to improve the SEO, the dns that wasn't working for me was aruba.odyssys.net – fratrik Apr 18 '18 at 20:00
  • How do you find the ip address of aruabe.odyssys.net? It comes up as 127.0.0.53 for me using dig and that's not a reachable address ...? – Ole Apr 23 '18 at 13:33
  • @Ole you need to connect to WIFI first, i.e. using your phone, and run ping -a aruabe.odyssys.net for example – Stepan Naumov Apr 26 '18 at 0:47
  • Yup got it - Thanks - I ended up just looking for the wifi router under general settings, and then added aruabe.odyssys.net and the ip address to /etc/hosts – Ole Apr 26 '18 at 1:24
0

The only workaround that I could find was to boot into Windows, connect, then boot back into Linux. Less than ideal but functional.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.