1

System's details:

  • OS: Ubuntu Mate 16.4.2 LTS
  • laptop: DELL latitude e6420
  • kernel: 4.13.0-32-generic (but I observed that the same happens for 4.13.0-26-generic)

The problem is that external usb mouse and keyboard stop responding completely. Then, when I suspend the system, and turn-it on again, everything works, usually! Any solution?

Reading usb stick seems to work without any issues.

In case it helps, the output of "lsusb" command is:

Bus 002 Device 005: ID 0a5c:5801 Broadcom Corp. BCM5880 Secure Applications Processor with fingerprint swipe sensor

Bus 002 Device 004: ID 0a81:0205 Chesen Electronics Corp. PS/2 Keyboard+Mouse Adapter

Bus 002 Device 003: ID 046d:c404 Logitech, Inc. TrackMan Wheel

Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub

Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Bus 001 Device 004: ID 1bcf:2a00 Sunplus Innovation Technology Inc.

Bus 001 Device 003: ID 413c:8187 Dell Computer Corp. DW375 Bluetooth Module

Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub

Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

I have not managed to find a permanent solution - I just suspend, then turn-on, etc. This is frustrating!

Any help?

Thank you all for "listening"

0

Cambiando el dispositivo de USB a otro USB trabaja de nuevo, si es el ratón a mi me funciona hacer desde la terminal (control+alt+t):

echo -n "0000:00:1d.0" | sudo tee /sys/bus/pci/drivers/ehci-pci/unbind
echo -n "0000:00:1d.0" | sudo tee /sys/bus/pci/drivers/ehci-pci/bind

Para no escribir tanto me hice un script bash (simplemente copia y pega en un editor de texto simple como xed, gedit, nano...):

#!/bin/bash

echo -n "0000:00:1d.0" | tee /sys/bus/pci/drivers/ehci-pci/unbind
echo -n "0000:00:1d.0" | tee /sys/bus/pci/drivers/ehci-pci/bind

Lo guardas en tu carpeta personal /home/TUUSUARIO con un nombre, por ejemplo ponraton.sh y lo haces ejecutable con el botón derecho de ratón sobre el mismo, en propiedades u Opciones - Permisos y marcas lo de ejectuar, en terminal sería: $ chmod 755 ponraton.sh Y ahora puedes ejecutar con sudo: primero Control+Alt+T en el teclado te abre la terminal y usas sudo ./ponraton.sh

Con teclado no sé porque uso portátil y no teclado USB. Me pasa de hace poco para acá, igual desde el paso del kernel al 4.13 desde 4.4 por culpa del fallo de los procesadores.

Google translates the above post to: Changing the USB device to another USB works again, if the mouse is working for me from the terminal (control + alt + t):

echo -n "0000:00:1d.0" | sudo tee/sys/bus/pci/drivers/ehci-pci/unbind
echo -n "0000:00:1d.0" | sudo tee/sys/bus/pci/drivers/ehci-pci/bind

To not write so much I made a bash script (simply copy and paste in a simple text editor such as xed, gedit, nano ...):

#!/bin/bash

echo -n "0000:00:1d.0" | tee/sys/bus/pci/drivers/ehci-pci/unbind
echo -n "0000:00:1d.0" | tee/sys/bus/pci/drivers/ehci-pci/bind

You save it in your personal folder /home/YOUR_USER with a name, for example switchmouse.sh and you do it executable with the right mouse button on it, in properties or Options - Permissions and marks what to execute, in terminal it would be: $ chmod 755 switchmouse.sh And now you can run with sudo: first Control + Alt + T on the keyboard opens the terminal and you use sudo ./switchmouse.sh

  • As this is an English only site, you should amend your answer to be in English – Graham Mar 4 '18 at 10:59

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.