0

I have an OLD GIGABYTE GA-EP43-UD3L Mother board in a PC that I've successfully loaded the latest Ubuntu on using a DVD. However, I'm thinking that re-usable USB Flash drives might be a better use of my money.

But, I used Etcher (recommended by Ubuntu) to create a bootable USB Flash drive on my Mac. Seems to work well, but whenever I insert the USB drive into my PC and power on, the Post screen displays and hangs there. Keyboard is dead, system will sit there forever with the Post screen displayed.

If I hold F12 during power on and go to the select Boot drive screen, I get 4 choices for USB

  • USB-FDD
  • USB-ZIP
  • USB-CDROM
  • USB-HDD

I talked to GIGABYTE tech support and was told to use USB-HDD. I put that into the Advanced BIOS boot order. However, nothing I've tried will get it past the Post screen.

Anyone have any ideas besides replacing the motherboard? I'll keep wasting DVDs before doing that.

  • 1
    Do you have more than one USB device plugged in; for example a external hdd and the usb-thumb-drive you wish to boot? Many motherboards (bios really) can only cope with a single memory device plugged in at boot and can stop dead, or just ignore usb-devices if there are many. Even some printers & devices you don't expect create this issue (though its usually multiple function type). Try using only usb-thumb-drive as only usb device at boot (plug in others later). note: i don't know your motherboard. – guiverc Feb 12 '18 at 22:34
  • My old motherboard had all those USB-xx settings and none worked. I later found that if I have a bootable flash drive plugged in and reboot, there is then another hard drive entry, not USB entry. – oldfred Feb 12 '18 at 22:38
  • PC has three HDDs. No USB devices except for keyboard and mouse. I'll take a look at booting from an alternate HDD and see if that works. Thanks for your input. – Hal Hackney Feb 13 '18 at 21:14
  • @oldfred dude, that was the answer. I never thought to look at the entries under Harddusj. When I looked just now, there were 4 entries, including the Sandisk Cruzer I'm using. Booted right up from it. Awesome. – Hal Hackney Feb 13 '18 at 21:21
1

The answer was extremely simple. @oldfred provided it with his comments to this question. The boot device (after hitting F12 to bring up the boot menu during Post screen), turned out to be the Sandisk Cruzer listed first under +Harddisk table.

I had never entered that part of the boot devices screen. I had only looked at USB devices. Booted right up from the Flash drive (USB Sandisk Cruzer).

0

After hours of frustration and reading every forum & blog I could find I have the solution. On the latest Gigabyte MB's like the H370M D3H you have to enable CSM Support. Once you do that viola, all USB drives are recognised at boot and Will launch the boot process.

Not the answer you're looking for? Browse other questions tagged or ask your own question.