2

My pc is a somewhat old Lenovo Ideacenter K410 tower. It originally came with Win7 preloaded. I updated the OS to Xubuntu 16.04 LTS and have been using that for 2+ years, but have JUST RECENTLY updated to 17.10.1. I tried using a USB audio interface, and each time I plugged it in, it seemed to freeze all audio on my pc. I tried rebooting with the device plugged in and with it unplugged, with the exact same frozen audio result. So I tried the following:

sudo apt-get remove alsa-base pulseaudio
sudo apt-get purge alsa-base pulseaudio
sudo apt-get install alsa-base pulseaudio
sudo start-pulseaudio-x11 start

None of that seemed to fix the audio issues. Now the audio seems to work barely, but with what sounds like Reverb always on, or maybe surround sound always on. I can't hear an mp3 song file fully - I hear the guitars, drums, but the singer sounds like they're on a different channel. Youtube playback sounds like it's underwater, with gurgling water sounds. It's really strange.

Ergo, why I upgraded to Xubuntu 17.10.1, I thought upgrading to a newer version would fix said audio issues. IT DIDN'T. The audio is still acting the same way.

I mostly use a 2-channel headphone plugged into the front, but have 5.1 audio output on the back from the motherboard that I rarely ever use.

Here is the output using the following terminal commands:

$ sudo aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC662 rev3 Analog [ALC662 rev3 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
---------------------------

$ sudo lspci -v | grep -A7 -i "audio"
00:1b.0 Audio device: Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller (rev 05)
    Subsystem: Lenovo 6 Series/C200 Series Chipset Family High Definition Audio Controller
    Flags: bus master, fast devsel, latency 0, IRQ 30
    Memory at f7d00000 (64-bit, non-prefetchable) [size=16K]
    Capabilities: [50] Power Management version 2
    Capabilities: [60] MSI: Enable+ Count=1/1 Maskable- 64bit+
    Capabilities: [70] Express Root Complex Integrated Endpoint, MSI 00
    Capabilities: [100] Virtual Channel
    Capabilities: [130] Root Complex Link
---------------------------

$ cat /proc/asound/version
Advanced Linux Sound Architecture Driver Version k4.13.0-32-generic.
--------------------------

$ cat /proc/asound/card0/codec#* | grep Codec
Codec: Realtek ALC662 rev3
Codec: Intel CougarPoint HDMI
-------------------------

$ cat /proc/asound/cards
 0 [PCH            ]: HDA-Intel - HDA Intel PCH
                      HDA Intel PCH at 0xf7d00000 irq 30
 1 [U0x46d0x9a4    ]: USB-Audio - USB Device 0x46d:0x9a4
                      USB Device 0x46d:0x9a4 at usb-0000:00:1a.0-1.4, high speed
-------------------------

$ lsusb
Bus 002 Device 005: ID 045e:0745 Microsoft Corp. Nano Transceiver v1.0 for Bluetooth
Bus 002 Device 006: ID 0480:0212 Toshiba America Inc 
Bus 002 Device 004: ID 05e3:0608 Genesys Logic, Inc. Hub
Bus 002 Device 003: ID 0bda:0184 Realtek Semiconductor Corp. RTS5182 Card Reader
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 004: ID 046d:09a4 Logitech, Inc. QuickCam E 3500
Bus 001 Device 003: ID 0764:0501 Cyber Power System, Inc. CP1500 AVR UPS
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
-------------------------

$ pactl list short sources
0   alsa_input.usb-046d_09a4_1D90F520-02.analog-mono    module-alsa-card.c  s16le 1ch 16000Hz   SUSPENDED
1   alsa_output.pci-0000_00_1b.0.analog-stereo.monitor  module-alsa-card.c  s16le 2ch 44100Hz   SUSPENDED
-------------------------

$ pactl list short sinks
0   alsa_output.pci-0000_00_1b.0.analog-stereo  module-alsa-card.c  s16le 2ch 44100Hz   SUSPENDED
-------------------------

$ pacmd list-sinks
1 sink(s) available.
  * index: 0
    name: <alsa_output.pci-0000_00_1b.0.analog-stereo>
    driver: <module-alsa-card.c>
    flags: HARDWARE HW_MUTE_CTRL HW_VOLUME_CTRL DECIBEL_VOLUME LATENCY DYNAMIC_LATENCY
    state: SUSPENDED
    suspend cause: IDLE 
    priority: 9959
    volume: front-left: 65536 / 100% / 0.00 dB,   front-right: 65536 / 100% / 0.00 dB
            balance 0.00
    base volume: 65536 / 100% / 0.00 dB
    volume steps: 65537
    muted: no
    current latency: 0.00 ms
    max request: 0 KiB
    max rewind: 0 KiB
    monitor source: 1
    sample spec: s16le 2ch 44100Hz
    channel map: front-left,front-right
                 Stereo
    used by: 0
    linked by: 0
    configured latency: 0.00 ms; range is 0.50 .. 371.52 ms
    card: 1 <alsa_card.pci-0000_00_1b.0>
    module: 7
    properties:
        alsa.resolution_bits = "16"
        device.api = "alsa"
        device.class = "sound"
        alsa.class = "generic"
        alsa.subclass = "generic-mix"
        alsa.name = "ALC662 rev3 Analog"
        alsa.id = "ALC662 rev3 Analog"
        alsa.subdevice = "0"
        alsa.subdevice_name = "subdevice #0"
        alsa.device = "0"
        alsa.card = "0"
        alsa.card_name = "HDA Intel PCH"
        alsa.long_card_name = "HDA Intel PCH at 0xf7d00000 irq 30"
        alsa.driver_name = "snd_hda_intel"
        device.bus_path = "pci-0000:00:1b.0"
        sysfs.path = "/devices/pci0000:00/0000:00:1b.0/sound/card0"
        device.bus = "pci"
        device.vendor.id = "8086"
        device.vendor.name = "Intel Corporation"
        device.product.id = "1c20"
        device.product.name = "6 Series/C200 Series Chipset Family High Definition Audio Controller"
        device.form_factor = "internal"
        device.string = "front:0"
        device.buffering.buffer_size = "65536"
        device.buffering.fragment_size = "32768"
        device.access_mode = "mmap+timer"
        device.profile.name = "analog-stereo"
        device.profile.description = "Analog Stereo"
        device.description = "Built-in Audio Analog Stereo"
        alsa.mixer_name = "Realtek ALC662 rev3"
        alsa.components = "HDA:10ec0662,17aa3653,00100300 HDA:80862805,80860101,00100000"
        module-udev-detect.discovered = "1"
        device.icon_name = "audio-card-pci"
    ports:
        analog-output-lineout: Line Out (priority 9900, latency offset 0 usec, available: no)
            properties:

        analog-output-headphones: Headphones (priority 9000, latency offset 0 usec, available: yes)
            properties:
                device.icon_name = "audio-headphones"
    active port: <analog-output-headphones>
---------------------------------

Any help is always graciously & humbly received. Since using Xubuntu exclusively for the past 2+ years, I really couldn't have kept at it without AskUbuntu's help. Thank you all for all the answers over the years.

So. What's up with my audio? Why am I hearing what sounds like Reverb with everything played? I have NOT added any sort of audio effects.

I am considering editing the following file, based on the instructions provided here: https://ubuntuforums.org/showthread.php?t=1043568

sudo gedit /etc/modprobe.d/alsa-base.conf
# add at the very bottom of the page 
options snd-hda-intel model=lenovo-3000 position_fix=1

I'll post an update if this fixes the problem.


UPDATE (1-2018):

  1. I applied the following edit:
  2. sudo gedit /etc/modprobe.d/alsa-base.conf
  3. << add at the very bottom of the page >>
  4. options snd-hda-intel model=lenovo 3stack-6ch-dig position_fix=1

I discovered if I adjust the BALANCE (using GNOME Alsa Mixer or Qasmixer) all the way RIGHT or LEFT, the audio sounds correct & centered, and the reverb & underwater effect goes away, even Youtube videos sound correct.

Not sure if this Update is the proverbial FIX. I mean, why would I need to adjust the BALANCE all the way RIGHT or LEFT?

NEW UPDATE (2-2018):

I just discovered the audio works great with the headphones ONLY, But only the left channel works with the pc speakers. The right channel is completely dead using the pc speakers.

  • sounds like reverb or underwater and presumably no such effects have been added to audio chain? delay effect is possibly caused by audio playback being mixed from 2 different sources with one slightly delayed – nik gnomic Feb 12 '18 at 15:21
  • no such effects have been added. So, what you @nik gnomic are saying is, that (possibly) PulseAudio & ALSA are mixing the same audio source at the same time, but with one apparently exhibiting some audio latency? ergo the reverb effect? – hienz1 Feb 12 '18 at 15:28
  • have recently learned how to update ALSA (ONLY if needed), by following instructions given here: wiki.ubuntu.com/Audio/UpgradingAlsa/DKMS – hienz1 Feb 15 '18 at 14:36
  • Considering uninstalling PulseAudio and using ALSA exclusively, using instructions here - hecticgeek.com/2012/01/… – hienz1 Feb 15 '18 at 14:37
  • 2
    yes it's a webcam. BUT there's an UPDATE to all this: I discovered if I adjust the balance all the way RIGHT or LEFT (using either GNOME Alsa Mixer or QASmixer), the audio sounds correct & in the center and the reverb & underwater effects go away. And youtube videos play back correctly too. – hienz1 Feb 18 '18 at 1:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.