4

I am using Konsole as a terminal to contribute to wikimedia pages. I use Konsole because unlike most terminal emulators it supports CTL (complex text layout) so I can clearly read my language (Tamil) in Konsole. The default terminal of Geany is not so good. I want to change the default terminal. How can I do that?

  • What version of Geany do you have? – DK Bose Feb 12 '18 at 11:34
  • 1.27 (Rezer-built on or after 2016-04-17) – info-farmer Feb 12 '18 at 17:03
  • Does any terminal appear in Geany? I have the same version but only see Status, Compiler, Messages, and Scribble. No terminal at all. – DK Bose Feb 12 '18 at 23:53
  • See settings.. Check here. Edit-->Preferences-->manyTabs-->Terminal – info-farmer Feb 13 '18 at 1:47
  • Sorry, I still don't see a terminal tab. I hope someone can help you! You could also sign up at lists.geany.org/cgi-bin/mailman/listinfo/users where Geany devs are available. – DK Bose Feb 13 '18 at 2:04
1

Way 1: You can change the terminal in the Tools tab in Geany's preferences.

In its Edit → Preferences dialog, Geany has a Tools tab. (This is separate from the Terminal tab.) One of the utility selections that you can configure from the Tools tab is Terminal.

screenshot showing Terminal selection in the Tools tab of the Preferences dialog in Geany

It has this as its default value, but you can change it to whatever you like:

x-terminal-emulator -e "/bin/sh %c"

So one way to make it use Konsole instead of whatever x-terminal-emulator is configured to run is to replace x-terminal-emulator with konsole. (Don't capitalize the k.) That is, one solution is to change that command to this one:

konsole -e "/bin/sh %c"

Geany itself substitutes for %c when it actually launches a terminal emulator. Whatever terminal emulator it calls does have to support a -e flag--or you can change that commmand accordingly if it doesn't. (Specifically what to write instead would depend on whatever syntax it did accept.) But most terminals do, and this includes Konsole.

Way 2: You can change what program x-terminal-emulator points to.

As an alternative solution that you might prefer, if you pretty much always want Konsole in any context where a terminal is opened, then you might want to just reconfigure x-terminal-emulator to launch Konsole instead of whatever other terminal it is currently launching.

If you choose to do this, then I recommend still checking in the Preferences dialog in Geany to make sure that it is actually using that x-terminal-emulator command shown above.

In Debian and Ubuntu, the x-terminal-emulator symlink is managed by the alternatives system. To adjust it so that it points to a different terminal command, you can run:

sudo update-alternatives --config x-terminal-emulator

You will be prompted to select one of the terminal emulators that is currently installed. Assuming Konsole is installed on your system, you should be able to select /usr/bin/konsole.

Acknowledgements

Zanna contributed substantially toward this answer.

See also the Geany manual (linked from this question, though that is not asking for the same thing, as the VTE is Geany's built-in terminal, which it sounds like you do not want to use).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.