1

I just did a fresh format and installed 16.04 (first) and now 17.10. Neither can pick any wireless up, and Bluetooth also seems broken.
Direct Ethernet connection works though.

Please forgive me this verbose question, I'm not sure what is relevant:

Internet says my wireless protocol: 802.11ac, Bluetooth 4.1

lsmod | grep r8:

r8169                  81920  0
mii                    16384  1 r8169

lspci -v:

02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 15)
    Subsystem: ASUSTeK Computer Inc. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
    Flags: bus master, fast devsel, latency 0, IRQ 279
    I/O ports at d000 [size=256]
    Memory at ef204000 (64-bit, non-prefetchable) [size=4K]
    Memory at ef200000 (64-bit, non-prefetchable) [size=16K]
    Capabilities: <access denied>
    Kernel driver in use: r8169
    Kernel modules: r8169

03:00.0 Network controller: Realtek Semiconductor Co., Ltd. Device b822
    Subsystem: AzureWave Device 2950
    Flags: fast devsel, IRQ 255
    I/O ports at c000 [disabled] [size=256]
    Memory at ef100000 (64-bit, non-prefetchable) [disabled] [size=64K]
    Capabilities: <access denied>

sudo lshw -C network:

*-network                 
   description: Ethernet interface
   product: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
   vendor: Realtek Semiconductor Co., Ltd.
   physical id: 0
   bus info: pci@0000:02:00.0
   logical name: enp2s0
   version: 15
   serial: b0:6e:bf:1b:72:3e
   size: 1Gbit/s
   capacity: 1Gbit/s
   width: 64 bits
   clock: 33MHz
   capabilities: pm msi pciexpress msix bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
   configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=full firmware=rtl8168h-2_0.0.2 02/26/15 ip=192.168.0.20 latency=0 link=yes multicast=yes port=MII speed=1Gbit/s
   resources: irq:279 ioport:d000(size=256) memory:ef204000-ef204fff memory:ef200000-ef203fff
*-network UNCLAIMED
   description: Network controller
   product: Realtek Semiconductor Co., Ltd.
   vendor: Realtek Semiconductor Co., Ltd.
   physical id: 0
   bus info: pci@0000:03:00.0
   version: 00
   width: 64 bits
   clock: 33MHz
   capabilities: pm msi pciexpress cap_list
   configuration: latency=0
   resources: ioport:c000(size=256) memory:ef100000-ef10ffff

1) I've disabled SecureBoot in BIOS -> SecureBoot disabled

2) Followed this:
Except for some complaints on the make install step about SSL certificates, everything ran. Didn't result in wifi, and also after reboot:

Kernel driver in use: r8168
Kernel modules: r8169, r8168

3) Then tried this (which is also this), which seems to be an easily installed driver. No errors, but also no apparent effect.

Am I even on the right track?

2

Am I even on the right track?

You are very close but you’ve missed a very important clue. The essential element in identifying the correct driver is the pci.id, usb.id or similar. You can find the pci.id for your device with the terminal command:

lspci -nnk | grep 0280 -A3

We suspect that you will find that it is: Realtek Semiconductor Co., Ltd. Device [10ec:b822]

When we search this very site for 10ec:b822, we find this answer: Asus Rog Strix Z370 EGAMING Wireless card not working

Therefore, I suggest that you follow the same procedure; with a temporary working internet connection, do:

wget https://github.com/lwfinger/rtlwifi_new/archive/extended.zip
unzip extended.zip
cd rtlwifi_new-extended
make
sudo make install
sudo modprobe rtl8822be

If, after the 'make' step, you have errors, please post them here. Warnings are probably alright.

You will have compiled the driver for your current running kernel only. When Update Manager installs a later one, also known as linux-image, after the requested reboot, re-compile:

cd ~/rtlwifi_new-extended
make clean
make
sudo make install
sudo modprobe rtl8822be
  • Wow, perfect. I should have asked this 3 days ago. A Million Thanks! – Roman Feb 12 '18 at 18:51
  • Uhm, do you know how to fix the bluetooth too off the top of your head? – Roman Mar 1 '18 at 23:32
  • I don't but Jeremy might! Please check here: askubuntu.com/questions/1003818/rtl8822be-bluetooth-device – chili555 Mar 1 '18 at 23:47
  • Hmmm, nope. I've looked at a couple of other guides, but no quick luck. Its not super important, so I guess I'll live with it for now... – Roman Mar 2 '18 at 23:47

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.