0

https://usn.ubuntu.com/usn/usn-3540-1/ ...............I am following this link to upgrade my kernel for Ubuntu 16.04.1 LTS

need help what is the exact kernel version do i need to update to

I am confused between linux-image-generic 4.4.0.112.118 and linux-image-4.4.0-112-generic 4.4.0-112.135 .............these are the 2 kernel versions mentioned on the URL

which one should I update my server to

Current Kernel Version on my OS is

# dpkg -l|grep linux-image 

ii linux-image-4.4.0-112-generic 4.4.0-112.135 amd64 Linux kernel image for version 4.4.0 on 64 bit x86 SMP 
ii linux-image-4.4.0-59-generic 4.4.0-59.80 amd64 Linux kernel image for version 4.4.0 on 64 bit x86 SMP 
ii linux-image-virtual 4.4.0.112.118 amd64 This package will always depend on the latest minimal generic kernel image. 


# uname -r 

4.4.0-59-generic 

# uname -a 

Linux ecs-nidhi-u16 4.4.0-59-generic #80-Ubuntu SMP Fri Jan 6 17:47:47 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux 

root@ecs-nidhi-u16:~# dpkg -l|grep -iE "kernel" 
ii dmeventd 2:1.02.110-1ubuntu10 amd64 Linux Kernel Device Mapper event daemon 
ii dmsetup 2:1.02.110-1ubuntu10 amd64 Linux Kernel Device Mapper userspace library 
ii kmod 22-1ubuntu4 amd64 tools for managing Linux kernel modules 
ii libdevmapper-event1.02.1:amd64 2:1.02.110-1ubuntu10 amd64 Linux Kernel Device Mapper event support library 
ii libdevmapper1.02.1:amd64 2:1.02.110-1ubuntu10 amd64 Linux Kernel Device Mapper userspace library 
ii libdrm2:amd64 2.4.67-1ubuntu0.16.04.2 amd64 Userspace interface to kernel DRM services -- runtime 
ii linux-headers-4.4.0-112 4.4.0-112.135 all Header files related to Linux kernel version 4.4.0 
ii linux-headers-4.4.0-112-generic 4.4.0-112.135 amd64 Linux kernel headers for version 4.4.0 on 64 bit x86 SMP 
ii linux-headers-4.4.0-59 4.4.0-59.80 all Header files related to Linux kernel version 4.4.0 
ii linux-headers-4.4.0-59-generic 4.4.0-59.80 amd64 Linux kernel headers for version 4.4.0 on 64 bit x86 SMP 
ii linux-headers-generic 4.4.0.112.118 amd64 Generic Linux kernel headers 
ii linux-image-4.4.0-112-generic 4.4.0-112.135 amd64 Linux kernel image for version 4.4.0 on 64 bit x86 SMP 
ii linux-image-4.4.0-59-generic 4.4.0-59.80 amd64 Linux kernel image for version 4.4.0 on 64 bit x86 SMP 
ii linux-image-virtual 4.4.0.112.118 amd64 This package will always depend on the latest minimal generic kernel image. 
ii linux-virtual 4.4.0.112.118 amd64 Minimal Generic Linux kernel and headers 
ii rsyslog 8.16.0-1ubuntu3 amd64 reliable system and kernel logging daemon 
root@ecs-nidhi-u16:~#

Please help me ASAP what exact packages do I need to update inorder to upgrade the kernel

0

Since you seem to be using the ordinary -generic kernel instead of an architecture-specific kernel, use 135 or higher.

Your output indicates that you already have 135 installed. Simply reboot into the new kernel using GRUB.

How to get to the GRUB menu at boot time

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.