1

i'm using windows 10 and ubuntu dual booting

i'll install plex server but it cannot access windows volume(C,D)

i'll run sudo chmod -R 777 gedit /etc/fstab and add volume on fstab file

run cat /proc/mounts and

add /dev/sda2 /media/virajlinux/New\040Volume fuseblk rw,nosuid,nodev,relatime,user_id=0,group_id=0,default_permissions,allow_other,blksize=4096 0 0)

and i'll try Plex Media Manager sees external NTFS drive but doesn't see directories

Plex Media Server: Won't find media External Hard Drive

but not work. i want to run plex without any effect run windows 10.

how i fix it? enter image description here

  • What have you tried? What is the output of lsblk? What happens when you mount the volumes? What have you added to /etc/fstab? Where did you run chmod -R 777? Do you get any error messages? Edit your question to include this information. – vidarlo Feb 13 '18 at 19:56
  • 1
    I'm having difficulty parsing "i want to run plex without any effect run windows 10." Could you add some clarity to that as well as the other information requested? Thank you for helping us help you! – Elder Geek Feb 13 '18 at 22:10
  • please edit your question and post the line(s) in /etc/fstab/where you have configured the NTFS drive(s) – Robert Riedl Feb 14 '18 at 9:27
  • i'll run cat /proc/mounts and add /dev/sda2 /media/virajlinux/New\040Volume fuseblk rw,nosuid,nodev,relatime,user_id=0,group_id=0,default_permissions,allow_other,blksize=4096 0 0 on fstab – VJ Ranga Feb 15 '18 at 14:59
  • but after reboot show only command line interface. then i'll removing a changes using nano /etc/fstab – VJ Ranga Feb 15 '18 at 15:17
0

You have a dual-boot system with Windows 10 and Ubuntu, Plex server installed on the Ubuntu partition. You want to read the Windows ntfs partions "C" and "D" but you don't want write access to make sure that Windows 10 runs without any issues later.

Assuming that your Windows partions are /dev/sda2 and /dev/sda3, put the following lines in /etc/fstab:

/dev/sda2                                  /media/virajlinux/C     ntfs         defaults,umask=002         0       0
/dev/sda3                                  /media/virajlinux/D     ntfs         defaults,umask=002         0       0

and point Plex to them accordingly. Windows drives are mounted at boot of the Ubuntu partition with the Plex media server, and they are read-only.

This should give you what you want.

0

I would suggest installing ntfs-3g (as mentioned in the comments)

sudo apt-get install ntfs-3g

then edit the fstabfile with your favorite ediotr

sudo nano /etc/fstab

to this

/dev/sda2 /media/virajlinux/New\040Volume ntfs-3g    permissions,locale=en_US.utf8    0   2

Disclaimer: There are a lot of options you can pass here, but with **permissions** you can do things likechmodorchown, which might help withplex`.

Then, if the volume /dev/sda2 is not mounted do

sudo mount -a

if you get an error similar to

mount: /dev/sda2 is busy 

then do

sudo umount /dev/sda2 && sudo mount -a
  • /dev/sda2 /media/virajlinux/New\040Volume ntfs-3g defaults,umask=002,locale=en_US.utf8 0 2is it correct – VJ Ranga Feb 22 '18 at 19:02
  • Should be fine, yes ! – Robert Riedl Feb 22 '18 at 19:07
  • i'll try it but it's not working. i'll update question – VJ Ranga Feb 22 '18 at 19:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.