If I boot from a Ubuntu USB live stick, everything works perfect on our belinea o.book 1301, but if I install Ubuntu from this stick with completely wiping the harddrive I end up with no wifi, touchpad and no USB support. Not even a USB-Stick or Mouse is recognized. and the Network-card neither, so I cannot install new packages at all.

But all these things work in the Live-System from the USB Stick! I tried all Ubuntu 16.04, 17.10 (17.10 is worse: there is no correct display settings either although it is perfect in the live-stick too) and even 18.04 beta.

Why isn`t the USB stick installing the same version on the system?

Output of lspci |grep -i net:

Ethernet controller: Realtek Semiconductors Co., Ltd. RTL8101/2/6E PCI Express Fast/Gbit Ethernet Controller (rev 02)
Network controller: Realtek Semiconductors Co., Ltd. RTL8187SE Wireless LAN Controller (rev 02)

Output in the USB-live-system of modprobe -c|grep rtl818x

alias pci:v000010ECd00008180sv*sd*bc*sc*i* rtl818x_pci
alias pci:v000010ECd00008185sv*sd*bc*sc*i* rtl818x_pci

In the installed system I get no output so there seems there is no RTL drivers installed.

I found some hints on this page, but that seems really hard to install without internet connection.

On the Realtec drivers page, there is only a driver for the old kernel 4.7. ;(

Note: solving the problem for the laptop of my friend is one thing, but I'd rather find a solution how to solve this for everyone:

How do I copy all drivers from the USB live system on my computer?

  • We need to get some basic information about your hardware configuration like a lspci stdout.
    – kcdtv
    Feb 12, 2018 at 19:00
  • Ok, thanks for updating, now we know that you have a realtek wifi chipset. Do not loose time with bcmwl: That is for broadcom chipsets. Can you try to run sudo modprobe rtl818x_pci and see what happens?
    – kcdtv
    Feb 13, 2018 at 18:44
  • Can't I just get all the drivers that are present in the life system to my real system then everything would work. I wouldn't care if there are some drivers too much
    – rubo77
    Feb 13, 2018 at 21:22
  • If I run sudo modprobe rtl818x_pci I get an error: module rtl818x_pci not found
    – rubo77
    Feb 14, 2018 at 21:46
  • 1
    17.10 is buggy I read and you have to use 17.10.1 instead. 16.04.1 works great for me but not sure about 16.04.3 if it has kernel 4.13 in the media. Also users report errors after updating. During install do you decline to update from the internet? That might shed light if it works without updating during installation. There are brand new driver fixes for my needs for Realtek WiFi: bugs.launchpad.net/ubuntu/+source/r8168/+bug/1635824 and Atheros WiFi: bugs.launchpad.net/ubuntu/+source/linux-firmware/+bug/1743279 so there might be other options out there for you. Feb 15, 2018 at 23:49

6 Answers 6


I've encountered similar problems in the past. As ever in these situations, the details matter. One solution that has worked for me is to boot the live image, "change root" into the not-working installed image, and use the live-setup's networking to allow the normal update procedure to properly install things. The precise procedure below:

  1. Boot the live image (e.g., USB, CD)
  2. Install Ubuntu to the HDD/SSD as per usual. Two details:
    1. As an aside, consider making multiple partitions, at least one for / and one for /home. This will make future updates or installations much easier. However, unless you know what you're doing, I might suggest sticking with the ext4 filesystem on each partition (unlike the link).
    2. I've generally had better luck not installing updates during this part of the process. You're choice of course, but we'll be doing the updates below, and the whole process at least feels faster if done later.
  3. When the installation finishes "Continue Testing" and don't reboot.
  4. Mount the newly minted root (/) partition by clicking the icon (one of the new gray platter/HDD looking items on the vertical bar to the left)
  5. Open a terminal ("Ack! I know!") via Ctrl+Alt+t -> A purple-looking window will appear

    Terminal example (cropped), akin to Live-image Ubuntu

  6. By clicking on the icon in step 2, Ubuntu Live mounted the hard drive to a directory in /media/ubuntu/. It will potentially be a weird directory name (technically a GUID), like 2801b1ba-d7d4-22e1-a6e3-0abcab51f05a. Task: "Change Root" into that directory with:

    sudo chroot /media/ubuntu/<directory_name>
  7. At this point, the shell (terminal) will run all commands as if on the new system, but with access to the working networking of the running kernel (the Live image). So, try a simple update and dist-upgrade (the command line equivalent to what the GUI does when updating your packages) and with luck, the correct packages will install themselves It doesn't always work, but this has been a surprisingly "simple" fix to a number of Live-boot vs installed-boot issues I've encountered:

    apt-get update
    apt-get dist-upgrade

I may have missed a step in terms of getting networking setup; if so, please leave a comment, and I'll update this answer when I can more thoroughly confirm each step of this procedure ("I'm not at my desk right now." :-) ).


Exact copy of the Ubuntu USB live system on my computer

You get an exact copy of the USB live system, if you clone the iso file to your internal drive. This will be faster than when booted from a DVD disk or USB pendrive.

It will be live-only, installed programs and tweaks will not survive shutdown or reboot. So this is not what you want.

Persistent live Ubuntu system in your internal drive

mkusb can create a persistent live Ubuntu system in your internal drive. It will work in the same way as a persistent live system in a USB pendrive. mkusb makes a casper-rw partition for persistence, and the size is only limited by the drive size.

Make a system with mkusb and use mkusb to create a persistent live system.

See the following links and links from them,

A persistent live system starts as almost an exact copy of the USB live system

  • You can install program packages,
  • you can tweak the system,
  • you can save data like in an installed system,

and these things will survive shutdown and reboot, they are persistent.

  • But the persistent live system cannot be and should not be completely updated & upgraded
  • and it is more sensitive to corruption compared to an installed system.
  • So you need frequent backups to keep it alive.

Installed Ubuntu system

It might be difficult to find the tweaks to make your particular computer hardware work with an Ubuntu installed system. But this is the best solution in the long run. Such a system can be completely updated & upgraded including linux kernel and all software can be up to date.

Depending on the particular hardware in the computer

  • can't I just copy somohow all drivers running in the USB-lilve system to the running system? I cannot find a howto for example how to activate the wlan card rtl818x_pci
    – rubo77
    Feb 15, 2018 at 12:14
  • The [persistent] live system brings all the drivers (which is what you asked for). You can try specifically with sudo modprobe rtl818x_pci. See this link, ubuntuforums.org/showthread.php?t=2368344 and the advice by @chili555. You can also create an own thread at the Ubuntu Forums, where there are several people who can help solving issues with wifi. The Ubuntu Forums is a good place to solve difficult problems in a dialogue or discussion about possible alternatives.
    – sudodus
    Feb 15, 2018 at 12:36
  • 1
    I don't really care to solve this single issue, because I don't get paid to fix my friends laptop ;) Isnt there a q'n'dirty solution to copy and all drivers like in the live-usb?
    – rubo77
    Feb 15, 2018 at 12:42
  • @rubo77, I only know one quick and dirty method, that of a persistent live system ;-) Let us hope someone is able to describe a method to install all drivers of the live system into an installed system :-)
    – sudodus
    Feb 15, 2018 at 12:45
  • @rubo77, You can also try with another version of Ubuntu. Different versions of Ubuntu bring different versions of the linux kernel, and the linux kernel brings its own set of hardware drivers. See the last link in my answer for more details.
    – sudodus
    Feb 15, 2018 at 12:55

Install but decline updates

To get the exact copy of the Live USB the best method is to not update the system during installation. Some users have experience bugs introduced by recent updates this year (2018):

Because of these and many other errors I haven't upgraded this year so far. I have manually installed Kernels though to keep ahead of Meltdown and Spectre.

By not applying any of the Ubuntu updates during installation and afterwards you are getting the closest possible system to the Live USB.

Wifi related updates

Here are a couple of similar questions where during Live-USB session Wifi works but breaks after installation:

  • if i decline updates and install ubuntu 16.04, i get the error trying to overwrite '/lib/systemd/system/console-setup.service', which is also in package keyboard-configuration 1.108ubuntu15.3 and the system is not running after install. only recovery console.
    – rubo77
    Feb 16, 2018 at 22:24
  • @rubo77 That bug has already been reported on lauchpad.net but Ubuntu Developers refuse to fix the bug because it was created by Kali Linux which isn't supported: bugs.launchpad.net/ubuntu/+source/console-setup/+bug/1588998 I suggest downloading a different copy of Ubuntu 16.04 and creating a new Live-boot USB. Feb 17, 2018 at 0:24
  • I tried Linux MInt and it worked now with declining updates and I selected not to install proprietary software. I'll try now with Ubuntu 16.04 again if that works too.
    – rubo77
    Feb 17, 2018 at 23:01
  • @rubo77 Because Linux Mint is based on Ubuntu it will hopefully work too. Feb 17, 2018 at 23:02
  • Does this mean, that if you decline updates, it installt the exact drivers that are running in the live-system? Or is this a lucky coincident, that the old version works and the automatic update breaks the drivers?
    – rubo77
    Feb 17, 2018 at 23:03

As mentioned in WifiDocs/Driver/bcm43xx community help page in Ubuntu Documentation:

A running LiveCD/LiveUSB environment has these packages (allowing the wireless to work), but an installed system may not. Make sure you have the linux-headers package that matches your current kernel version, plus the appropriate generic header packages so that they are automatically updated on a kernel upgrade.

to get it done, please follow the instruction provided in this page.

I hope this helps in solving your problem.

  • I now started the live-system, then copied locally and then install all .deb packages from that page, but then I get the error Module wl not found in directory /lib/modules/4.8.0-53.... That page only explains it for Ubuntu 14.04. Can you add the essential parts here, how I could solve this (without Internet connection)?
    – rubo77
    Feb 13, 2018 at 12:12
  • Do I need the bcmwl-kernel-source from this page or from the LIve-stick in the folder /cdrom/pool/restricted/b/bcmwl? Also there is no folder /cdrom/pool/main/p/patch on my 16.04 live-stick
    – rubo77
    Feb 13, 2018 at 12:21
  • yes, it's documented for 14.04. That's from the official web that i found. here's my workaround. I haven't tried this but, try to download from other connected computer kernel&headers. Then: firmwares. After that, install. In theory, it should be working. Feb 14, 2018 at 9:15
  • I get an error that's the wrong kernel version. I have 4.8.0-53
    – rubo77
    Feb 14, 2018 at 21:44
  • here: link . found from this answer Feb 15, 2018 at 0:45

Check BIOS settings,

Mainly UEFI / LEGACY makes the problem worse. I recommend try installing it in Legacy mode once. and reply if everything went ok!...

Also check :

uname -a

in both the conditions in live boot & after installing.

If not matching download the kernels versions where they work perfect nd install it with

dpkg - i

Download all kernels related files headers and all ".deb"

  • On the live-CD I have uname -r 4.10.0-28-generic while after install i get 4.8.0-53 ... thats strange too!
    – rubo77
    Feb 15, 2018 at 3:13

Ensure that your USB-Installer is Clean

Usually, if you install from USB, all drivers are used exactly as on the USB-installer. If you selected to download upgrades during install, you will get an even newer driver version if available, which normally isn't a problem either.

If you end up with a non working system, the reason could be your USB installer medium. E.g. if you use unetbootin to create your USB installer, a common error could be, that you just overwrite an existing old installer on the USB-drive without deleting the existing folders. This can end up in an installer that has a lot of "leftovers" of the old installer, that are then copied into your new system, and cause havoc there.

So be sure, you delete all Installer related files on your USB-drive before writing the content of a new installer-image onto it via unetbootin. Then your install will probably work fine as expected.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.