0

"Launch skype in the background" is not an option now so I'm trying to bypass it. I tried to add this line to the autostart file:

&& sleep 5 && xdotool windowminimize $(xdotool search --onlyvisible --class Skype)

but this command opens skype as an empty window and I dunno why.

I tried to make a cron:

@reboot sleep 60 && xdotool windowminimize $(xdotool search --onlyvisible --class Skype)

It doesn't work as well and I dunno why.

Can you tell me why these options doesn't work for me and how to make them behave itself? :D

Tnank you!

1

This seems to be an XY problem. Newer versions of Skype does support starting in the background. Go to Tools > Settings and toggle on "Launch Skype in the background".

enter image description here

  • 1
    I have the latest version and it produces unclosable window if this option selected. – Александр Захаров Feb 10 '18 at 11:21
  • Strange! Works fine here, Skype v8.15.0.4 on Ubuntu 17.10. – pomsky Feb 10 '18 at 11:40
  • Same version, but Ubuntu 16.04. I googled this problem and I'm not the only one who faced it. Good opportunity to learn shell scripting:D – Александр Захаров Feb 10 '18 at 11:49
0

I updated to 17.10 and switched from Unity to Gnome. It fixed the problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.