0

Hi i just changed the root password using "sudo passwd" without any error, then i closed the terminal and i opened another terminal, i've tried to access root using "sudo -s" and it doesn't let me log in, saying that the password is wrong.

i've tried even using the old one but nothing, and i'm pretty sure to know the new password because before typing i wrote it down on the paper.

I'm still logged in the same session, i don't want to log out or restart because i think it will impossible to recover the password if i log out right?

  • 2
    sudo -s is your password, not the root password. Ubuntu has the root account disabled by default. Setting a password to root enables the account which is not recommended. See askubuntu.com/questions/687249/… – Terrance Feb 9 '18 at 18:31
  • Ah... so when i did "sudo passwd" i changed the sudo password.. and if i type "sudo -s" i'm logging the sudo account right? so why i can't access it anymore? – dada Feb 9 '18 at 18:47
  • No, you changed the root password. sudo asks for your password, not root's. To change your password, type passwd without sudo in front in a terminal. – vidarlo Feb 9 '18 at 18:58
  • I've tried and it say "Authentication token manipulation error" – dada Feb 9 '18 at 19:01
  • Think of sudo as "Super User DO". It is not an account, it is a command. You use the command for elevated purposes. If you messed up your account password, you might need to reboot your host into Recovery Mode and reset your own password. See sudo.ws/man/1.8.2/sudo.man.html and for password recovery see askubuntu.com/questions/24006/… – Terrance Feb 9 '18 at 19:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.